I run XFCE 4.10 in Archlinux and I have had my mouse (and/or XFCE) behaving weirdly for a couple of days.

The mouse works fine when I first start XFCE. I can interact normally with UI features. However, when I launch an application (i.e. Firefox), the mouse pointer will stop to interact with the UI elements of XFCE although it still works within the application. For example, I can click on bookmarks and the navigation buttons of Firefox, but clicking on the panels and the window frame buttons will not be registered until I close the application with Alt-F4.

If I close Firefox and restart it, the mouse even refuses to work within Firefox. Unplugging and replugging it makes it interact again with Firefox but not with XFCE. However, if I completely unplug the mouse, I can use the trackpad successfully both in XFCE and in Firefox!

Note that I used Firefox as an example. Same issue with Thunderbird, urxvtc, etc. May it be some issue with the drivers? Note that (re)installing xf86-input-mouse does NOT solve the issue.

I think it may be be some issue related to how XFCE deals with focus and mouse input, but I have no idea where to look. I have looked around in the forums but I could not find any related issues. Could anybody help me see where to start troubleshooting? Thanks!

1 Answer 1


Believe it or not, my totally tech-naive partner solved the issue by changing the mouse. I still cannot fathom how the old mouse worked selectively in applications and stopped to work in the desktop environment, but here we go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .