1

I've installed Ubuntu 14.04.2 LTS on the same hard drive as my Windows 8.1 OS, on its own partition. The installation went without any hickups.

After that I used EasyBCD on my windows system to create a new boot entry for Ubuntu (Using GRUB 2).

Again, this worked fine, and starting either system via the boot menu also worked as it should.

I then let the auto-updater for Ubuntu install its updates and ever since that I cannot start Ubuntu anymore. If I try, it leaves me with this message (Right after choosing Ubuntu from the boot menu):

Try (hd0,0): NTFS5: No ang0
Try (hd0,1): NTFS5: No ang0
Try (hd0,2): Extended:
Try (hd0,3): invalid or null
Try (hd0,4): non-MS: skip
Try (hd0,5): Extended:
Try (hd0,5): EXT2:

Nothing else happens after that. Starting windows still works fine however.

I've check the partitions with the disk management utility in windows, and everything seems to be in order:

http://puu.sh/gnu2H/e8f1754b20.png

The two unnamed partitions are the /swap and root-partitions for Ubuntu.

What could be causing this sudden change? Everything was fine until I ran the autoupdater.

I've seen a similar question on here, but the problem there was with an UEFI-BIOS (Which I don't have).

1

Use liveCD, find partition where ubuntu is installed (use Gparted -similar partitioning program. Mount the partition (Ext4-usually):

sudo mount /dev/sda1 /mnt

(where partition name is sda1 else sdb1, sda2 etc...).

Now bind

sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys

Then

sudo chroot /mnt

grub-install /dev/sda

(notice sda not sda1 - else disk which is bootable)

grub-install --recheck /dev/sda
update-grub

Also you may check /etc/default/grub using liveCD (gedit/kate) after mounting the Ext4 partition for any incompatibilities.

I have not used windows for a long time. May be Win8 does not allow GRUB2 entries, I have no experience with EasyBCD. ref to the help/man pages of EasyBCD, you may find something there.

  • Is it really necessary to have your name twice under your post? You edit your post if you have additional information, commenting on your own post should be reserved for non-essential/non-relevant material – Anthon Mar 5 '15 at 16:36
  • Thank you, that did the trick on the first try! I would give this an up-vote, but I don't have enough reputation for that yet... – Silverlan Mar 6 '15 at 16:10
  • thank you for sharing this, worked absolutely great for me. now i m greeted with two startup screen, one from grub and when i select windows 7 then it shows the BCD Menu. is there a way of removing the BCD menu completely. – Sudhir Kesharwani Apr 18 '16 at 19:06
0

Had the same problem after updating my Windows 7... fixed by resetting easy BCD. I had to clear all preset menu options and then re-add the new entries pointing to the correct drive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.