1

I'm dual booting Windows 8.1 and Linux Mint. I decided to install the Linux Mint OS (Rebecca) onto an EXTERNAL HDD.

So what I did was click "Something Else" during installation and I created 3 partitions on the External HDD.

    1. EFI Partition
    1. Swap Partition
    1. Root "/" Partition

Note: There's no more free space after that. The above 3 partitions took all of it (as intended).

Then at the very bottom, I chose to install the bootloader to /dev/ssd instead of /dev/sda.

When I was finished installing mint and I booted into windows, I ran the following batch file as Administrator:

@echo off
mountvol b: /s
taskkill /F /IM explorer.exe
start explorer.exe
start explorer.exe

Then I went to my Windows (Internal HDD) EFI partition.. And there it is! GRUB is installed in the EFI folder as "Ubuntu":

enter image description here And when I check my BIOS, there's 2 new options to boot "Ubuntu". I don't want this. I want to have everyone only on the external drive (EFI partition and all). It has to be possible. I did it with my hackintosh (Clover EFI) but can't seem to figure out how to do it with GRUB..

No matter what I do, it keeps messing with my internal MBR and installing to the internal EFI partition. Would be even better if I can just boot it without grub.

Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.