0

I have Linux Mint 17.1 and am trying to dual boot Windows 10 Technical Preview OR install it on my other hard drive. Extra easy damage-control for you guys- I do not care if I lose any data, as long as I can have this computer run lua so I can practice programming and software development (I have nothing to save), I don't care if I need to re-install an operating system from scratch.

My goal: Get Windows 10 Technical Preview up and running in any way possible so I can have fun helping the Windows 10 team's development. If I need to buy a bigger disc to fit it on, let me know what disc I need to get.

Short story: I followed a Windows 7 from Ubuntu guide, hoping it would all work for Windows 10 Technical Preview from Linux Mint 17.1.

My steps that got me here:

  • Download Windows 10 .iso
  • Mount to 700MB CD-RW !fails- disc too small
  • Mount to 16GB USB
  • Restart computer -> BIOS: set boot to USB !fails- look at 2.
    1. USB not on priority list
    2. USB is below that on optional boot list !fails- "Error 15: File not found"
    3. move USB to different slot, same fail each time
  • Follow How to install Windows 7 from Ubuntu without burning a disc - Ubuntu Sharing
    1. Download grub4dos via guide's link
    2. Extract to Downloads folder
    3. Terminal: sudo mv /my/grub.exe/is/here /root
    4. GParted: create new 4GB NTFS partition !fails- option is gray/can't click
    5. Restart computer -> BIOS: set boot to CD
    6. MiniTool Partition Wizard Free 9.0: create new 4GB NTFS partition
    7. Terminal: sudo mount /my/iso/is/here /mnt -o loop !fails- "mount: block device /my/iso/is/here is write-protected, mounting read-only"
    8. Come here to cry.
4
  • Are you sure it failed? The message you quoted isn't an error (and says it mounted, even). Mar 5 '15 at 2:16
  • So read-only isn't a problem? I'll have to check when I get home to the computer. Maybe I overreacted when seeing a statement that I didn't know the purpose of it telling me, so I assumed it either succeeded only partially or failed completely. Can't get back home for at least two days because of this shitty weather.
    – VanCleef
    Mar 5 '15 at 3:08
  • It's a CDROM image, those filesystems are read-only by design. Use mount -oro ... to indicate you want to mount read-only and you won't get the error; the default is to mount read-write, but that's impossible with this filesystem type, hence the warning message.
    – wurtel
    Mar 5 '15 at 7:59
  • Thanks you two :) I guess I just need to keep going with the guide. Should I update this because I'm probably the only one documenting this method?
    – VanCleef
    Mar 6 '15 at 10:00
0

It would be much easier to install windows first, then install ubuntu. Ubuntu's bootloader will check for other operating systems during installation and include them in the boot menu, where Windows is pretty strict, only showing windows unless you add other entries manually.

0

A few notes:You didn't "mount" the image to a USB stick - you copied it. You can only "mount" a USB-Stick (or image) to a folder which is only a temporary state.It's the same thing like in Windows where you have the partition C. Booting Linux, you wouldn't have 'C' but just some NTFS-partition. But you can mount it, to access it. Windows uses Drive Letters as mountpoints (usually), Unix&Linux paths. Farther down:Maybe your machine is an UEFI machine? In this case I have not found any way to create an USB of a Windows image to make use of BIOS/MBR and UEFI. In case you have UEFI there are 2 options:

  • Use it:
    1. You need to format the USB as FAT32 using GPT partition table layout.
    2. Then extract the iso and copy all its contents over to the USB (ie.: mount the USBs only partition, copy, unmount)
  • Use MBR layout:
    1. Just use dd bs=4 if=/path/to/iso of=/dev/sdX where sdX is the unmounted device descriptor. It will be something like sda,sdb but do not append any number like sdc2 as this denotes a partition. We want to directly write to the device.
    2. In the UEFI settings enable "Legacy USB" mode.

Either way, you now shold be able to boot from the USB (select in bootmenu etc).

If you do not have UEFI you only can go the MBR way. There won't be a legacy mode you need to activate. It seems though, that you have UEFI.

After that, install Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.