1

I am trying to run DQN, which is some AI for Atari.

Upon launching the program (sudo bash run_cpu < the_name_of_the_game >), I get the following error: run_cpu: line 46: 9377 Segmentation fault ../torch/bin/luajit train_agent.lua $args

From Running application ends with "Segmentation Fault", the error seems to be coming from the program, but many other people have used it without any problem ...

How can I solve this?

I'm quite new to Linux, and I'm on Elementary OS (+-latest stable version)

I took the program here : https://sites.google.com/a/deepmind.com/dqn/

closed as off-topic by slm Aug 21 '18 at 2:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Which game are you training DQN on? Could you try without sudo? – Stephen Kitt Mar 4 '15 at 23:10
  • @StephenKitt I have tried breakout and a 3D tic-tac-toe game. I have tried without sudo, it gives me the same error (just the number changes, it's still around 10000, that should be the process's ID (?)) – Hippalectryon Mar 4 '15 at 23:14
  • Does the game program work on its own? – Hack Saw Mar 4 '15 at 23:53
  • @HackSaw Do you mean the roms or the DQN ? I have tried several ROMs so they should be ok, and the DQN has been run successfully by other people. – Hippalectryon Mar 4 '15 at 23:55
  • I mean the game itself. If the game works outside of the learning framework, this suggests it's not the problem. – Hack Saw Mar 5 '15 at 0:01
1

Is the ROM name capitalized? If so, make it lower case. For example:

    Breakout.bin ==> breakout.bin

Also make sure that you have 6GB of RAM!

  • Why do I need 6 GB or RAM ? (I only have 4) – Hippalectryon Mar 8 '15 at 14:14
  • Because the network is large and all the training happens in memory. – Rahul Mar 9 '15 at 10:18
0

The instructions are possibly misleading for a newbie. Let's say you have a game called "happy". The command line you type would be:

./run_cpu happy

That is, don't include the < or >.

In any case, you generally don't need to use sudo unless you get a permissions error.

  • I didn't include them, I just ran (for example) sudo bash run_cpu breakdown. – Hippalectryon Mar 4 '15 at 23:50
  • I use sudo because otherwise I get a 'Permission Denied' error. (sorry for being unclear in my question) – Hippalectryon Mar 4 '15 at 23:57
  • That's odd. At the top level of the Human_Level_Control_through_Deep_Reinforcement_Learning directory, try this command: "sudo chown -R $your_user_name ." This will ensure everything in the directory is owned by you. – Hack Saw Mar 5 '15 at 0:06
  • My concern is that something else has the wrong permissions, and a program is getting an error message instead of the expected output, which might cause a seg fault. – Hack Saw Mar 5 '15 at 0:10
  • "sudo chown -R $hippa" gives me a 'chown: missing operand' error – Hippalectryon Mar 5 '15 at 0:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.