1

Unfortunately, the school I currently work at has one of the wonkiest, worst-configured clusters I've ever used. And the IT department is totally incompetent and blames the users for basic issues. This may be unrelated, but I digress.

The system vim is very outdated and I want to be able to use my vimrc from my home computer to streamline my work. Unfortunately, the vim on the cluster does not support autocompletion. My solution was to try to install vim locally. I pulled vim from the github repo and compiled it, then installed it with

make DESTDIR=~/.local
ln -s ~/.local/usr/bin/vim ~/bin

This now gives me an up to date vim which can support the plugins that I want. I get an error:

Error detected while processing /a/home/cc/tree/taucc/students/enginer/nicholas/.vimrc:
line    4:
E484: Can't open file /usr/share/vim/syntax/syntax.vim

line 4 in my vimrc is simply:

syntax enable

This error does not happen with the default /bin/vim, and I'm not sure why. Actually, /usr/share/vim/syntax doesn't even exist. I tried to search the cluster for syntax.vim, but naturally it will take a long time (the cluster is huge) and I don't have access to the vast majority of directories. Any ideas?

EDIT: I suppose this is fairly obvious, but actually the vim folder pulled from github has a /runtime/syntax director with syntax.vim in it. Great. So I'm assuming I need to fix my vim runtimepath so that vim searches there?

1 Answer 1

0

I don't think you've properly compiled and installed Vim, that's why it's still attempting to read from the default runtime path.

As you have to install Vim locally to your home directory, that is usually done via

./configure --prefix=$HOME/.local [...other configure options here...]
make && make install

See src/INSTALL (chapter Installation Names) for more details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .