1

I've found a conflict between automatic line breaks in vim and the neocomplete Vundle plugin. When neocomplete is off, then my set textwidth=80 option works correctly, i.e. a line break is inserted automatically when I type past the 80 character limit.

However, when neocomplete is activated, it doesn't work as I'd expect. When I type past 80 characters, the line doesn't automatically break, and I keep typing beyond that limit. Then, when I hit Enter, the hard line breaks are inserted where they should've been automatically been inserted previously, and my cursor ends up one line below all of the newly formatted text.

I went through my .vimrc and changed the different options I had set for neocomplete but found that none of them seemed to cause the issue. Merely turning neocomplete on results in this behavior.

I'm running arch-linux, which I just switched to a little over a week ago. I was running Xbuntu before that, and I had neocomplete working with no such issues. Here's my .vimrc: http://pastebin.com/A4H9E0SA

Can anyone replicate this issue with neocomplete and/or have any ideas as to how to fix this without completely removing the plugin?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.