0

When I insert my USB or enter a DVD with Kali installer in it, it all works fine until I'm in the installation window (after I reboot the computer).

I press the Kali Live option on the menu and wait until it finishes loading. After it is done I suddenly get a black screen with a white little bar at the top left. I can't press or write anything (and no I don't have a mouse cursor on the screen).

What can it be? I downloaded the last Kali version 1.10 and tried 1.09 as well which I had a while ago. The same disks and USB worked perfectly on my laptop.

Here's a picture:

enter image description here

More information about my computer:

enter image description here

enter image description here

When I try to add the nomodeset option in the boot I get this:

enter image description here

  • I think you need to tell us more about the machine having this problem - what CPU, memory and preferably the motherboard, as evidently the problem is hardware-specific. Probably you need to enter some special override setting at the boot screen. – gogoud Mar 3 '15 at 12:13
  • I added more information, is it enough or am I missing something? – Naor Hadar Mar 3 '15 at 12:16
  • try adding the kernel option: nomodeset – gogoud Mar 3 '15 at 12:48
  • I cant seem to add that option anywhere in the menu.. Can i do it through windows? – Naor Hadar Mar 3 '15 at 13:25
1

updated info based on comments:

In grub menu, press c to open a command-line then type vbeinfo. Make a note of an available resolution e.g. 1366x768, then type reboot.

Back in grub menu for 2nd time, type e and add GRUB_GFXMODE=1366x768 right after load_video (or edit it if GRUB_GFXMODE= is already present) - use a resolution that you confirmed was available. It should be added to the second line. Then press F10 to boot.

If you are just installing the system, you might find that after installation it reboots fine. If not, you can make the change permanent (so you don't have this palaver every time you boot) by editing /etc/default/grub e.g.

gksudo gedit /etc/default/grub

and adding a line:

GRUB_GFXMODE=1366x768 (or whatever is appropriate in your case)

After saving this change you need to run update-grub:

sudo update-grub

Explanation: the default video mode doesn't work on your system, this forces it to use a specific video mode which you have checked is available.

  • It didnt work.. Still I get the same window.. :/ – Naor Hadar Mar 3 '15 at 13:56
  • When I try to add it it says that the command was not found – Naor Hadar Mar 3 '15 at 13:57
  • I added a photo now – Naor Hadar Mar 3 '15 at 14:02
  • I think you added it in the wrong place probably, use the cursor keys to move to the place where you see load_video, after that add a space and the word nomodeset, then type CTRL+x or press F10. If this doesn't work let me know. – gogoud Mar 3 '15 at 14:06
  • I dont get an error now but i still get the black screen as soon Kali finishes loading.. :/ – Naor Hadar Mar 3 '15 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.