2

$ sysctl -a | grep acl kern.features.ufs_acl: 1 vfs.acl_nfs4_old_semantics: 0 $ mount /dev/ada0p2 on / (ufs, local, journaled soft-updates) devfs on /dev (devfs, local, multilabel) devfs on /var/named/dev (devfs, local, multilabel) $ setfacl -m u:spamd:rwX ham setfacl: ham: acl_get_file() failed: Operation not supported $ getfacl ham # file: ham # owner: spamd # group: spamd user::rwx group::r-x other::r-x

Any attempts to set acls with setfacl gives the same error, even commands copied directly from the man page.

  • 1
    Don't you have to enable acl's as one of the mount options? – mdpc Mar 3 '15 at 3:41
  • Aha! Yes you do. Doh. – lbutlr Mar 3 '15 at 3:52
4

The mount option acls must be specified to use ACLs, like such:

mount -o acls /dev/ada0p2 /

Or in fstab, like so:

/dev/ada0p2 / ufs rw,acls 1 1

This should make ACLs usable.


PS. Yes, I know this was answered in the comments just wanted to post this for completeness and so the question can be marked answered. Also, please specify the version of FreeBSD you are using when posting questions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.