1

Impossible to change the resolution on wheezy to 1920x1080 I'm stuck and I'd down a bit as 1360x768.

At the beginning in nvidia-settings i only had the choice to 1920x1080, after adding: Option "ModeValidation" "AllowNonEdidModes" in my xorg.conf any resolutions are listed but black screen when i want to change ...

Same problem with xrandr when I change:

xrandr --output LVDS-0 --mode 1360x768 --rate 60 ==> black screen

I tested lot of solution but nothing happens, now i think the problem is edid and kms; I got the file edid.bin from nvidia-settings and try to add in my grub default.

GRUB_CMDLINE_LINUX_DEFAULT="quiet drm_kms_helper.edid_firmware=edid/edid.bin"

OR 

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset nouveau.modeset=0"

But again no change, do you have a solution before I steal the magic wand of my niece ?

Attachement :

$ xrandr

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080      60.0*+   59.9     40.0  
   1680x1050      59.9  
   1440x900       59.9  
   1400x1050      60.0  
   1360x768       60.0     59.8  
   1280x1024      60.0  
   1280x960       60.0  
   1152x864       60.0  
   1024x768       60.0  
   ...
DP-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

$ cat /etc/X11/xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.88  (pbuilder@cake)  Wed Apr  3 08:58:25 UTC 2013

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.48  (pbuilder@cake)  Wed Sep 12 10:54:51 UTC 2012

    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Configured Mouse"
        Option         "Xinerama" "0"
    EndSection

    Section "InputDevice"

        # generated from default
        Identifier     "Keyboard0"
        Driver         "keyboard"
    EndSection

    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "Name" "Razer Razer Diamondback 3G"
        Option         "CorePointer"
        Option         "Device" "/dev/input/mice"
        Option         "Protocol" "ExplorerPS/2"
        Option         "Buttons" "9"
        Option         "Resolution" "1800"
        Option         "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Chi Mei Optoelectronics corp."
        HorizSync       44.0 - 67.0
        VertRefresh     40.0 - 60.0
        Option         "DPMS"
    EndSection

    Section "Device"
        Identifier     "Video Card"
        Driver         "nvidia"
    EndSection

    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 670M"
        Option         "NoLogo" "on"
        Option         "ModeValidation" "AllowNonEdidModes"
    EndSection

    Section "Screen"
        Identifier     "Default Screen"
        Device         "Video Card"
        Monitor        "Monitor0"
        Option         "NoLogo" "1"
        Option         "RenderAccel" "1"
        SubSection     "Display"
            Modes      "nvidia-auto-select"
        EndSubSection
    EndSection

    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.