6

Trying to install tor-browser on my Linux Mint 17 system, I screwed up my sudo privileges.

I wanted to run the command:

sudo chown $USER -Rv /usr/bin/tor-browser/

but instead I typed

sudo chown $USER -Rv /usr/bin/ tor-browser/

and then the ownership and permissions went out the door.

Now I get a message every time I want to use sudo:

sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set
1
  • 1
    First, a directory owned by your regular user in /usr/bin is a really weird idea... For the current problem, the files in /usr/bin should be owned by root, but a dozen or so have also lost their setuid bit like sudo. The simplest would be to use the package manager. I'm finding apt-get --reinstall install but there may be something more fine-grained ...
    – Leiaz
    Commented Mar 2, 2015 at 14:06

2 Answers 2

11

First restart the pc, press SHIFT key while Ubuntu is booting.

This will bring you up the boot menu.

Go to Advanced Options.

Select your OS version in (recovery mode), and press Enter Key.

example : Ubuntu 14.04 (recovery mode)

It will bring you up another screen. Now select “Drop to root shell prompt” and press Enter.

It will load a command line at the bottom of the screen.

Now run each of the following commands.

# mount -o remount,rw /
# mount -a
# chown root:root /usr/bin/sudo
# chmod 4755 /usr/bin/sudo
# init 6

This will fix your sudo Above error.

5
  • 5
    This will only fix sudo. If the OP was trying to change permission of a directory, there is certainly more to fix.
    – Leiaz
    Commented Mar 2, 2015 at 12:18
  • Thank you very much - it worked like a charm. There was a time that I was fluent in DOS, up to V 6, as a matter of fact, but the Win GUI made me lazy. This is a new challenge... Thanks for the prompt help.
    – Merciless
    Commented Mar 2, 2015 at 12:33
  • That is a marvelous answer. It saved a lifetime for me. after all struggling and wrong answers I found on internet, This actually solved the issue Commented Nov 26, 2015 at 8:26
  • 1
    Please do not do this, this will only partially fix the issue. You may have surprises in the future.
    – ob_dev
    Commented Apr 19, 2017 at 9:09
  • Then you provide the correct solution Commented Apr 19, 2017 at 18:10
0

The other answers(s) may fix any short term problems, but stuff in /usr, more so in /usr/bin or /usr/sbin, should never get permission changes or be touched by the user directly. The permissions on some files are VERY specific and you won't find a comprehensive guide on repair of this. To quote the immortal WOPR, "The only winning move is not to play". AKA, just don't do this.

The only sure-fire repair is to re-install the OS and learn that with sudo comes great responsibility. Not all posts on the internet are correct. Typos will burn you. And always double/triple check before you press enter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .