5

Here's my friend's laptop configuration:

  • Linux Mint & Windows 8.1
  • Intel Core i7-3537U
  • NVIDIA Kepler GeForce GT 740M & Intel HD 4000
  • 4Go RAM

All the drivers are up to date


Here's the issues:

  • The processor is 60°C in idle;
  • The battery long for only 1h30 instead of at least 3 hours with Windows 8.1

What I've done:

  • Try the 3 proposed drivers => didn't change the battery life;

enter image description here

  • Search for greedy applications with top => the CPU load do not exceed 5%.

Here's powertop result:

Usage       Évènements/s    Catégorie       Description
100,0%                      Device         Codec audio hwC0D0 : Realtek
 16,0 ms/s      62,6        Process        /usr/bin/X :0 -audit 0 -auth /var/lib/mdm/:0.Xauth -nolisten tcp vt8
 18,4 ms/s      55,8        Process        /opt/google/chrome/chrome --type=renderer --enable-deferred-image-decod
 11,6 ms/s      56,7        Process        /opt/google/chrome/chrome
 14,7 ms/s      31,3        Process        cinnamon --replace
265,0 µs/s      25,4        kWork          od_dbs_timer
511,2 µs/s      22,5        Interrupt      [4] block(softirq)
  1,0 ms/s      15,7        Process        /usr/sbin/mysqld
  2,0 ms/s      10,8        Timer          hrtimer_wakeup
  5,7 ms/s       7,8        Process        gnome-terminal
181,0 µs/s       9,8        kWork          ieee80211_iface_work
 90,3 µs/s       7,8        Process        [rcu_sched]
276,8 µs/s       5,9        kWork          os_execute_work_item
469,3 µs/s       3,9        Process        /opt/google/chrome/chrome --type=gpu-process --channel=2623.0.147618803
  4,3 ms/s       2,0        Process        powertop
  2,6 ms/s       2,0        Interrupt      [6] tasklet(softirq)
467,3 µs/s       1,0        Timer          tick_sched_timer
270,8 µs/s       1,0        Interrupt      [7] sched(softirq)
 93,1 µs/s       1,0        Process        /usr/lib/accountsservice/accounts-daemon
 50,3 µs/s       1,0        Process        /usr/sbin/apache2 -k start
 45,3 µs/s       1,0        Process        [khugepaged]
  8,5 µs/s       1,0        kWork          ath_tx_complete_poll_work
  2,8 µs/s       1,0        kWork          flush_to_ldisc
  0,0 µs/s       1,0        kWork          bdi_writeback_workfn
  0,8 ms/s      0,00        Process        [kworker/u8:7]
  0,8 ms/s      0,00        Interrupt      [50] nvidia

Questions:

  • Is the dedicated graphic card draining the battery? If so, how can I choose the enabled GC?
  • What (else) can I check?
  • 1
    Inspect the power consumption with powertop. Especially have a look at the last tab “Tunables”. – Marco Mar 2 '15 at 8:20
  • 1
    Please edit your question and tell us which drivers you tried (since you seem o have tried more than one). Does the laptop have switchable graphics or does it only have the NVIDIA card? – terdon Mar 2 '15 at 11:13
  • @terdon it have an intel HD4000 and I've tried the 3 proposed by Mint... – Thomas Ayoub Mar 2 '15 at 12:59
  • Please edit your question to add extra detail, it is hard to read and easy to miss in the comments. Which were these three proposed by Mint? You say you have an HD4000, does that mean you have both an onboard chip and a dedicated card? If so, that would explain the difference in battery use. – terdon Mar 2 '15 at 13:17
  • @terdon done editing :) – Thomas Ayoub Mar 2 '15 at 14:05
1

Problem

You don't have a battery hogger. You have an incorrectly configured driver.

  1. You have a NVIDIA Optimus Powered Graphics System
  2. Optimus is not pure NVIDIA. It is an Intel Graphics Card( Intel HD 4000) used to drive a discrete NVIDIA Card(GeForce GT 740M)
  3. Linux Mint has the required option, VGA_SWITCHEROO, on by defult, therefore all your graphics output is being processed by the intel driver, and sent to the NVIDIA card for display only. The extra processing of sending everything to the discrete card is what consumes the battery, as using the pure NVIDIA driver does not honor the VGA_SWITCHEROO option.

vga_switcheroo is the kernel mechanism that allows you to switch between GPUs if your machine has a hardware mux. Note that this method is not supported by all machines and only works if you are using the opensource driver (nouveau, radeon) and not the proprietary ones (nvidia, fglrx).


Solution

To fix this, you need to install the Bumblebee Hybrid Driver using the following answer as a Guideline:

how to install nividia bumbulbee in linux mint 17.1 (cinnamon)?.

The reason I say guideline is this: Remember to replace the driver version in /etc/bumblebee/bumblebee.conf with the appropriate version of the NVIDIA Driver. Right now, they are equal, but as this answer ages the version will change.


See Also

Ubuntu Wiki - Bumblebee
Nvidia Optimus (Intel + Nvidia) on Linux Mint 17.1 Cinnamon - This one is a bit outdated, but I added it, so readers would know about the Bumblebee Repository

  • The linked guideline says nvidia-331 everywhere. In my settings it is "nvidia-current". Which, I assume, always uses the right version for my system. Right? – donquixote Jun 11 '16 at 22:22
  • You need to test with nvidia-current. If that doesn't work, then the version matters. – eyoung100 Jun 11 '16 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.