2

When vlc is running, the screen goes blank every 10 minutes. This requires to move the mouse or hit keyboard periodically when watching a movie.

This happens even after disabling the screensaver, in vlc:

  • VLC → Tools → Preferences
  • Show settings 'all' → Video → Disable Screensaver
  • not reproducible, unix.stackexchange.com/a/440550/3285 – Evan Carroll Apr 28 '18 at 8:17
  • Not reproducible in your case... Please note that this was a self answered question, to help people facing the same problem. – ederag Apr 28 '18 at 16:31
  • see my update in my answer for proof. – Evan Carroll Apr 28 '18 at 17:49
  • "Proof" was not needed, but the supplement of information makes your answer useful. – ederag Apr 28 '18 at 19:18
  • 1
    I observe this bug with VLC 3.0.5-1-0-g653c0c1ca8 and xdg-screensaver 1.1.3+ on Fedora 29, KDE 5 (kded5 5.53.0, plasmashell 5.14.4). – Nemo Jan 18 at 16:44
4

The option to disable the screen saver, should work. At least now it sends the input to X11. So that will work. I have verified that it works for me despite having xset q report with VLC 2 and 3.

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0

History and Background: Internally, VLC uses xdg-screensaver to inhibit the screensaver. There were a series of patches since this request that both addressed DPMS and KDE (cinnamon). If this problem persists, consider upgrading your xdg-screensaver script (it's just a bash script).

For me, vlc is calling xdg-screensaver reset which calls xscreensaver-command-deactivate which is documented as

This tells xscreensaver to pretend that there has just been user activity. This means that if the screensaver is active (the screen is blanked), then this command will cause the screen to un-blank as if there had been keyboard or mouse activity. If the screen is locked, then the password dialog will pop up first, as usual. If the screen is not blanked, then this simulated user activity will re-start the countdown (so, issuing the -deactivate command periodically is one way to prevent the screen from blanking.)

  • 1
    Nice to know it has been solved upstream, in a cleaner way. – ederag Apr 28 '18 at 19:19
  • 1
    @ederag yes. I can't confirm it's been solved but it seems highly likely, I can only say it no longer is reproducible under VLC 2, or VLC 3. However, check out the xdg-screensaver script above and try spamming xdg-screensaver reset and see if you can get your screen saver to go off. (no VLC needed, since any bug here involves xdg-screensaver and not vlc) – Evan Carroll Apr 28 '18 at 19:22
  • cloned the repo, ./configure, make, ./scripts/xdg-screensaver reset, the screensaver still activates. But openSUSE 42.2 is old now;your solution might help others. – ederag May 5 '18 at 22:02
  • @ederag did you make install or is vlc using the system's xdg-screensaver? Vlc will find the xdg-screensaver by using the environmental $PATH. – Evan Carroll May 6 '18 at 5:40
  • 1
    No "passion" here, I just pursued out of respect for the time you took to answer. My system is obsolete, and fine with my solution. I will not file a bug report before upgrading. For the record, here is the xdg-utils version used: git describe --abbrev=40 --always --dirty=+ yields c7ecf26e036c7a5f8a921d12c7efe1435f3e996b. (this is the latest one) – ederag May 6 '18 at 17:29
1

The problem is that the X screensaver is still enabled, as shown by typing xset q on the command line:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600

The solution has been given in this thread. Just issue xset s noblank -dpms on the command line.

But it is more convenient to create a ~/bin/disable_xsc.sh file containing

#! /bin/bash

# disable the X screensaver
# The kde screensaver should still work, though
# http://opensuse.14.x6.nabble.com/Disabling-display-power-management-td3039820.html

xset s noblank -dpms

exit 0

Make sure that this script is executable

chmod u+x ~/bin/disable_xsc.sh

otherwise you would get a blinking "kwrite" in the taskbar, kde hanging, the taskbar responding very slowly, firefox would hang on startup, ... if you forgot to chmod, just kill the offending kwrite process, and issue the chmod command.

Finally, going to the kde

configure desktop -> system administration -> startup and shutdown -> Autostart

Add script in the "shell script path", type ~/bin/disable_xsc.sh, leave the "Create symlink" checked. This script will be run on startup.

Note that the kde screensaver will still work correctly, when vlc is not running. Its configuration can be found in

configure desktop -> Hardware -> Display and monitor -> screen locker

  • Upgrading xdg-screensaver, as suggested in Evan's answer, is probably a better solution now. – ederag Apr 28 '18 at 19:21
  • For some reason, Evan's suggestion does not work on my system. – ederag May 6 '18 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.