1

I just built GNU Midnight Commander 4.8.13 from source and the directory hotlist is now invoked with CtrlBackspace instead of Ctrl\.

This is a PITA since it seems to not be passed through via ssh -- or else it plain does not work, this is a remote system so that's the only access I have.

Rather than sorting that out, I'd prefer to have the old Ctrl-\ back, but I could not find anything relevant in the .configure options and it seems to be hard-coded in. Is there anything I can do?

1

You'll have to recompile, but this is not hard to fix. First, make clean.

Edit mc-4.8.13/src/keybind-defaults.c. Find line 104/105:

/* To access the directory hotlist */
{"HotList", "ctrl-backspace"},

Change that to:

/* To access the directory hotlist */
{"HotList", "ctrl-\\"},

Configure as before and make && make install; done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.