1

I'll try to be brief and include all the things I've tried out so far:

  • Guest OS: Debian Wheezy
  • Host OS: Windows 7
  • Setting networking to NAT works.
  • Setting networking to host-only works as well.
  • Setting networking to bridged (the one I need) does not work.
  • VBox Additions are up-to-date (first removed the Debian packages and reinstalled the ones provided by VirtualBox).
  • ifconfig shows the device
  • Setting an IP-Address manually with ifconfig eth0 <unused-ip> and then pinging a server in the network range does not work (Destination Host Unreachable)
  • I also set up a default route, but as it's on the same network (a simple /24 net), that should not (and does not) make a difference.
  • The Host has two NICs. I completely disabled the one which is unused. Just to make sure that VirtualBox is not being confused.
  • Running dhclient eth0 does not work.

Looking into /var/log/messages I can see the network device reacting when I disconnect/reconnect it via the VirtualBox interface:

Mar  1 11:27:23 sleeperian kernel: [ 1895.172149] e1000: eth0 NIC Link is Down
Mar  1 11:27:33 sleeperian kernel: [ 1905.193469] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX

What I find most curious, is the error from ping (Destination Host Unreachable). The IP-Address and Netmask are correct (pinging 192.168.1.1 btw):

eth0      Link encap:Ethernet  HWaddr 08:00:27:25:a9:32  
          inet addr:192.168.1.13  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe25:a932/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:182 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:30241 (29.5 KiB)

What am I missing?

  • your eth0 has to has default gw. – PersianGulf Mar 1 '15 at 10:47
  • I set up a default route (bullet point #9). Also, this is only necessary if you are accessing (f.ex. pinging) an address outside of your network. This would be the case for internet access. But I was pinging one of the network hosts, so the default route should not be necessary. Nevertheless, I set one up without any luck. – exhuma Mar 1 '15 at 11:17
  • What kind of NIC is on the host? A bridged virtual network works by putting the NIC on the host into promiscuous mode, which doesn't always work with WiFi NICs. – Mark Plotnick Mar 1 '15 at 19:20
  • It's a desktop machine with an on-board NIC. I am not on that machine, but it is a Marvell Yukon something something :) And I think I already had bridged networking working at some point. Not sure though if it was on the same machine. I will double check the "promiscuous" mode setting though. VBox has a setting for that where you can allow/forbid it. But I think that setting is okay. Could it have something to do with UAC? – exhuma Mar 2 '15 at 15:52
  • @MarkPlotnick The problem was promiscuous mode! The default setting was "Deny" in virtual box, and I did not touch the default. Changing it to "Allow VMs" made it work. If you will formulate your comment as answer, I will accept it. – exhuma Mar 2 '15 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.