2

Very recently git has started merging even though I have set it to always rebase:

$ git config --list | grep -F branch.autosetup
branch.autosetuprebase=always
$ git pull
[Removed everything in the commit message]
error: Empty commit message.
Not committing merge; use 'git commit' to complete the merge.
$ git merge --abort

It was definitely a trivial merge, because:

$ git pull --rebase
First, rewinding head to replay your work on top of it...
Applying: [...]
$ echo $?
0

Is this a known issue?

$ git --version
git version 2.3.1
3

Turns out branch.autosetup only takes effect on new branches, creating a repository-local branch.[branch].rebase=true setting. To set this retroactively for the master branch:

$ git config branch.master.rebase true

My bad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.