0

I did an apt-get update/upgrade today and my Subversion is giving me grief now.

I am still a new user with Debian so I was not aware that sometimes a reboot is required after one of these updates. I may have messed some things up.

I am running currently: debian 7, gnome 3.4.2, subversion 1.7.19

Attempting to svn update or svn commit, I get 'segmentation fault' with no other indicator of what is wrong.

The rest of my system seems to work fine so far as I can tell.

What could be causing my issue?

closed as off-topic by psusi, cuonglm, Michael Homer, Networker, John WH Smith Apr 2 '15 at 10:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – psusi, cuonglm, Michael Homer, Networker, John WH Smith
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This may be due to unofficial packages. If you don't have such packages, you can write a bug report. With gdb, you can see where the crash occurs. This can give you some idea of the cause of the problem. – vinc17 Feb 27 '15 at 17:49
  • @vinc17 that is a good call. this subversion was from a 3rd party repo so i could get a newer version to run. i dont know much about gdb do you have a link where i can read about it? – GraphicO Feb 27 '15 at 18:22
  • apt-get install gdb, but anyway, a crash from a Subversion coming from a 3rd-party repo is not surprising, since the ABI's may be different, unless it claims to be Debian-compatible (note: Debian derivatives are not necessarily compatible with Debian). If you want a newer version, use backports if available, or compile it from source. – vinc17 Feb 27 '15 at 18:37
  • the only bug gdb caught was 0x00007ffff642f959 in free () from /lib/x86_64-linux-gnu/libc.so.6 – GraphicO Feb 27 '15 at 18:41
  • Assuming you are running the official debian package of subversion, you need to report a bug to debian. Also, stop using subversion and move to a modern DVCS, like git, bzr, or hg ;) – psusi Apr 2 '15 at 3:03
1

I was getting exactly the same issue on Debian Wheezy with svn 1.7.19-1+WANdisco, with the same error reported when running in gdb.

Looking at the stack trace (bt) in gdb showed the problem to be related to Gnome Keyring integration (libsvn_auth_gnome_keyring). I worked around the problem by disabling this in ~/.subversion/config by disabling external password stores: password store =

FWIW Gnome Keyring integration seemed to work correctly with the SVN 1.8 build from WANdisco (but I had to downgrade to 1.7 for other reasons).

Not the answer you're looking for? Browse other questions tagged or ask your own question.