1

I just updated my system and upon reboot I've found myself in emergency mode. This is a dm-crypt+LUKS EFI system (thinkpad) using gummiboot. journalctl -xb reports that /boot could not be mounted. Following this thread, I tried downgrading my kernel to 3.18.2 using pacman -U, and while it did downgrade, I still can't boot normally.

Thinking the kernel upgrade process just caught a glitch, I tried re-updating my kernel (from /var/cache/pacman/pkg/, but that didn't affect the next boot. mkinitcpio gave a warning that the boot partition wasn't mounted.

The line currently in my /etc/fstab is:

LABEL=EFI /boot vfat rw,relatime,fmask=0022,dmask=0022,code page=437,iocharset=iso8859-1,short name=mixed,errors=remount-ro 0 2

uname -r tells me the emergency mode is using Linux kernel 3.18.2 instead of the 3.18.6 kernel I updated to. pacman -Q says Linux 3.18.6-1.

Journalctl -xb | grep -I failed | less shows that systemd failed to load display manager and failed to start Load Kernel Modules. Two units failed according to systemctl --state=failed.

When I startup and when I try and connect to the internet with netctl, I get the codepage cp437 error and am prompted again for my root password. Further investigation reveals that this is the MS-DOS/FAT extended ASCII encoding specified for my EFI partition in /etc/fstab. If this is just a misalignment between /boot and /, how could I resync them past pacman -U?

I'd really appreciate suggestions for restoring my system. Thanks in advance.

  • Chroot in, make sure that /boot is mounted and pacman -Syu && mkinitcpio -p linux. – jasonwryan Feb 27 '15 at 7:02
1

jasonwryan pointed me in the right direction.

I performed the following steps:

1) downloaded latest installation media and made a bootable USB

2) unencrypted my LUKS LVM volumes

3) mounted my volume to the live USB file system in /mnt/arch, a directory I created (including /mnt/arch/boot, and /mnt/arch/home)

4) connected to the internet with wifi-menu

5) used arch-chroot to change root

6) updated with pacman

7) rebooted

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.