2

I have a ext4 drive that is mounted using defaults mount options. It is a RedHat Enterprise Linux version 6.5, 64 bits. I can call lsattr on any file on that server.

I need to share that drive with 3 other servers, all running the same version of RHEL. And I need to read extended attributes with lsattr on any of the 4 servers.

When mounting the drive with this command:

mount -t nfs s1.example.com:/a/b /a/b -o rw,sync,hard,intr,user_xattr

I tells me user_xattr is incorrect:

mount.nfs: an incorrect mount option was specified

How can I mount an exported drive and keep the ability of calling lsattr on those files?

How I share the disk is not important, as long as lsattr works. Those RHEL are actually Virtual Boxes on Windows 7, so even Virtual Box Shared Folder (vboxsf) would do. I tried, didn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.