• BeagleBone Black running Debian 7.7
  • nmcli tool, version

I tried some command examples to get started, however none helps me to add a connection and connect.


# nmcli dev
DEVICE     TYPE              STATE        
wlan0      802-11-wireless   disconnected     <====
usb0       802-3-ethernet    unmanaged    
eth0       802-3-ethernet    connected 


I have few

nmcli con    
NAME                      UUID                                   TYPE              TIMESTAMP-REAL                    
Wired connection 1        00000000-4a11-43d1-9252-4b92de0e75c3   802-3-ethernet    Thu Oct 23 05:46:02 2014          
WLAN-A69E22               29eeb2f6-cf80-0000-0000-d23733e97eb4   802-11-wireless   Thu Oct 30 16:06:14 2014          
Wireless connection 1     bfaa9524-a1d9-0000-8279-71a56720c06c   802-11-wireless   Wed Feb 24 02:33:55 2015          
Wireless connection 2     00000000-d5cc-411b-a62e-000000000000   802-11-wireless   Wed Oct 22 23:31:24 2014   


nmcli dev wifi list
SSID                              BSSID               MODE             FREQ       RATE       SIGNAL   SECURITY   ACTIVE  
'MAR'                       00:00:00:86:D0:22   Infrastructure   2462 MHz   54 MB/s    80       WEP        no      
'MYHOME'                    00:00:00:00:2D:16   Infrastructure   5180 MHz   44 MB/s    80       WPA WPA2   no

I'd like to add a new Wireless connection to SSID MYHOME using nmcli and I want to connect to it.

The docs I find don't seem to match my version of nmcli

For Fedora, I found out that the following would work see here

nmcli con add con-name MyCafe ifname wlan0 type wifi ssid MyCafe ip4 gw4



# nmcli con help
Usage: nmcli con { COMMAND | help }
  COMMAND := { list | status | up | down | delete }

  list [id <id> | uuid <id>]
  status [id <id> | uuid <id> | path <path>]
  up id <id> | uuid <id> [iface <iface>] [ap <BSSID>] [--nowait] [--timeout <timeout>]
  down id <id> | uuid <id>
  delete id <id> | uuid <id>


# nmcli dev help
Usage: nmcli dev { COMMAND | help }

  COMMAND := { status | list | disconnect | wifi }

  list [iface <iface>]
  disconnect iface <iface> [--nowait] [--timeout <timeout>]
  wifi [list [iface <iface>] [bssid <BSSID>]]

none seem to allow to create connections

A few outputs

nmcli -f GENERAL,WIFI-PROPERTIES dev list iface wlan0

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           802-11-wireless
GENERAL.VENDOR:                         Realtek
GENERAL.PRODUCT:                        802.11n NIC
GENERAL.DRIVER:                         rtl8812au
GENERAL.HWADDR:                         04:8D:38:0F:D9:32
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         42 (The supplicant is now available)
GENERAL.UDI:                            /sys/devices/ocp.3/47400000.usb/musb-hdrc.1.auto/usb1/1-1/1-1.3/1-1.3:1.0/net/wlan0
GENERAL.NM-MANAGED:                     yes
GENERAL.CONNECTION:                     not connected
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
  • 1
    Assuming Ubuntu respects Debian's package numbering, the changelog seems to indicate that the feature was added in ("Add ability to connect to new WiFi networks from nmcli"). FWIW it is accessed via the dev object rather than the con object, so nmcli dev wifi connect <SSID> password <PASS> iface <IFACE>. Commented Feb 25, 2015 at 2:19
  • Ok let me see if I can update the package.
    – zabumba
    Commented Feb 25, 2015 at 8:35
  • @joelmaranhao: Have you succeeded? How did you go about updating it to the next version? Have a different issue also requiring a newer version but apt-get upgrade will keep it at 0.9.4. Commented May 30, 2015 at 10:28
  • upgrade to 0.9.10, it's a big update.
    – iman
    Commented Aug 20, 2015 at 3:25

2 Answers 2


nmtui is an alternative command for nmcli which is based on Text User Interface

as root just type


enter image description here

  • this is the one and only solution that worked for me (fedora 23) after countless nights of cli hacking without any reasonable results. why the fuck is this so stupid simple and no one writes it in any existing wiki?! thanks a lot GAD3R! Commented Apr 3, 2016 at 19:53
  • 1
    nmtui and nmcli are neither available commands on my Debian 8 install. What gives?
    – Arya
    Commented Jun 5, 2017 at 2:31
  • 1
    @Arya nmtui is a part of network-manager package packages.debian.org/…
    – GAD3R
    Commented Jun 5, 2017 at 10:11
nmcli device wifi con "ssid" password "p455w04d"
  • 2
    Thanks for this. I really don't understand why password requires a bareword/argument/command and SSID does not. Commented Oct 25, 2018 at 3:03
  • 1
    @pdoherty926 A poor workaround is to run the command as in the response with the password in the clear but the wrong password. Then you can use nmcli connection up "ssid" passwd-file <path to file>
    – MrMas
    Commented Mar 19, 2019 at 23:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .