1

I am running Debian Wheezy on a BananaPi.

I just compiled the kernel and the keyboard was working in terminal(if it's called that way). However, after I installed a dekstop interface using "apt-get install task-lxde-desktop" my keyboard did not respond anymore. This is my dmesg and lsusb... Notice how weird the lsusb looks

root@bananapi:~# lsusb
Bus 003 Device 003: ID 04ca:002f Lite-On Technology Corp.
Bus 004 Device 003: ID 2808:81c9
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
root@bananapi:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

root@bananapi:~# dmesg   (last part of it)
[  301.255226] usb 4-1: new full-speed USB device number 3 using ohci-platform
[  301.470215] usb 4-1: No LPM exit latency info found, disabling LPM.
[  301.494962] hid-generic 0003:2808:81C9.0005: hiddev0: USB HID v1.10 Device [Focaltech Systems FT5926 MultiTouch] on usb-1c1c400.usb-1/input0
[  301.504628] input: Focaltech Systems FT5926 MultiTouch as /devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1/4-1:1.1/0003:2808:81C9.0006/input/input3
[  301.504694] hid-multitouch 0003:2808:81C9.0006: input: USB HID v1.10 Device [Focaltech Systems FT5926 MultiTouch] on usb-1c1c400.usb-1/input1
[  381.565209] usb 3-1: new low-speed USB device number 3 using ohci-platform
[  381.799992] input: Lite-On Technology Corp. USB Multimedia Keyboard as /devices/platform/soc@01c00000/1c14400.usb/usb3/3-1/3-1:1.0/0003:04CA:002F.0007/input/input4
[  381.855227] hid-generic 0003:04CA:002F.0007: input: USB HID v1.10 Keyboard [Lite-On Technology Corp. USB Multimedia Keyboard] on usb-1c14400.usb-1/input0
[  381.867586] input: Lite-On Technology Corp. USB Multimedia Keyboard as /devices/platform/soc@01c00000/1c14400.usb/usb3/3-1/3-1:1.1/0003:04CA:002F.0008/input/input5
[  381.925522] hid-generic 0003:04CA:002F.0008: input,hiddev0: USB HID v1.10 Device [Lite-On Technology Corp. USB Multimedia Keyboard] on usb-1c14400.usb-1/input1
[  403.888550] usb 4-1: USB disconnect, device number 3
[  405.680680] usb 3-1: USB disconnect, device number 3
  • 1
    I had exactly the same problem and the only thing that helped was using older kernel (3.16) in my case. I've noticed that 3.18 kernel works fine too. – Victor Polevoy Apr 15 '15 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.