This message appears in my dropdown terminal at seemingly random times when no processes is running in that terminal:

Message from syslogd@debianator at Feb 24 18:57:58 ...
 kernel:[43089.321139] Disabling IRQ #43

I guess I can disable it from being printed with dmesg -n 1 but what does the message mean?

  • 2
    Might indicate it's having trouble with some hardware device. Check /var/log/messages (or your distro's equivalent) for a full stack trace and you can check /proc/interrupts to see what that IRQ number is associated with.
    – Bratchley
    Feb 24, 2015 at 21:14

3 Answers 3


The message states that the kernel is disabling an interrupt, ie. (usually) ignoring messages from some hardware. This can for example be due to a conflict between two hardware components. You can have more informations about what is using an interrupt with commands like lspci -v or cat /proc/interrupts.

  • it is my "Network controller: Ralink corp. RT2600 802.11 MIMO", it never worked well I dont know why, so I keep and use just a USB WIFI. But I kept that PCI card there. Do you think I should remove that PCI card? Sep 18, 2021 at 4:13
  • @AquariusPower If you can not make it work (tweaking its IRQ or avoid conflicts), then better remove it. It will save power and avoid errors. That said I saw this from time to time and never noticed any impact (performance or stability).
    – Uriel
    Sep 19, 2021 at 20:15
  • Now I remember, it worked better than USB Wifi to have more stable and lower ping for games, but it was like more than 10years ago if I am not wrong, and that card was installed on an even older PC (that used DDR2 RAM I think). May be I am just deluded by good memories xD, I should just remove that card. Sep 19, 2021 at 21:30
  • Today my PC would just not boot, not even open the BIOS setup, would not load the boot loader (grub), but the keyboard was still working (capslock/numlock) on a black screen. I did many things, but only when I removed that old PCI card, it booted again! Oct 9, 2021 at 0:42

Received a similar message to this a while ago. Discovered it was a hardware issue with how interrupts were passed from the PCI controller to PCI-Express controller (Intel PCI6466 chipset). Check deeper into the logs, look for: irq 43: nobody cared (try booting with the "irqpoll" option)

There are several things that can cause this including incorrect drivers.

  • To check deeper into the logs I suppose I should figure out how journalctl works - or is there be a better place to start? Feb 26, 2015 at 11:51
  • I'm not familiar with how debian does logging. I use RHEL 6 so I typically use "grep -i kernel /var/log/messages | grep -i irq | less"
    – pacmanwa
    Feb 27, 2015 at 21:55

In your case, interrupt 3 is usually the console serial aux port - which if you have ttyS1 attached, you'll probably find it is now dead. IRQ 4 is the primary console port

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .