The symlink libssl.so.6 shows up in /usr/lib/x86_64-linux-gnu, and I ran ldconfig but I still get this error:

error while loading shared libraries: libssl.so.6: cannot open shared object file: No such file or directory

Is it a permissions issue or the link is not properly defined?

Update after running ldd on the binary:

    linux-vdso.so.1 =>  (0x00007fff1efe2000)
    libssl.so.6 => not found
    libcrypto.so.6 => not found
    libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007feb2a3c4000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007feb2a1bb000)
    libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007feb29f82000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007feb29d65000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007feb29b60000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007feb297a1000)
    /lib64/ld-linux-x86-64.so.2 (0x00007feb2b159000)
  • Run the ldd command on the binary that is showing this error and update your question with the output. – devnull Feb 24 '15 at 17:22
up vote 9 down vote accepted

From the ldd command it looks like the binary is looking in /lib/x86_64-linux-gnu and not /usr/lib/x86_64-linux-gnu where you found the symlink.

Try running these and see if you still get the same error:

sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /lib/x86_64-linux-gnu/libcrypto.so.6
sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /lib/x86_64-linux-gnu/libssl.so.6
  • I ran similar 'sudo ln' commands without understanding what's going on, but things work fine now! – blueseal Feb 24 '15 at 19:54
  • 1
    @blueseal, ln -s creates a symlink from the libssl.so.1.0.0 binary to libssl.so.6 filename in the /lib/x86_64-linux-gnu directory. sudo permissions are needed as /lib is a root directory. – devnull Feb 24 '15 at 19:55
  • I can't upvote, but I really appreciate your effort for the clarification! – blueseal Feb 24 '15 at 20:27
  • @blueseal, don't worry. Glad to help! – devnull Feb 24 '15 at 20:35
  • I try ln not works, but I move these to the lib dir works – Kris Roofe Jan 6 '17 at 6:59

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.