3

I just installed the debian 7 wheezy, but WiFi is not working. I visited the debian wiki pages but they have already mentioned there that the broadcom chip BCM43142, 4e4:4365 is not supported by the drivers packages 43xx etc

what to do please help.?

it works fine when I installed Windows.

but not on debian distribution .

1 Answer 1

1

This might be in interest of yours.

At first get the driver:

sudo apt-get install linux-headers-generic build-essential dkms broadcom-sta-modules

1st package isn't essencial.

download this package

Install it:

sudo dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

And run:

sudo modprobe wl
1
  • I have not tried your solution but got tired of trying to just enable my laptop WiFi, even I tried Ubuntu, Fedora, Kali and debian. and with all of them I had the same problem. so I just uninstalled it for now, will try that . thanks
    – CuCu
    Feb 25, 2015 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .