1

I am unable to install any vim plugins on nixOS

running the command:

nix-env -i vimplugin-Syntastic

gives these as the last 3 lines of output:

output path ‘/nix/store/3bcdjr4hwgrimcimdg2115prpfm83xca-syntastic-4782184’ should 
have r:sha256 hash ‘1vjh3a3w6whvaws86z48j8bp7dgavvix8a2kgjn195axs83hpkxy’, instead has 
‘01a1px7i77ajc4y8czwhkhhqif89q6yf26wpjakh3asdv7cvnidm’

cannot build derivation ‘/nix/store/478msfr0bm6h64zp0ri5c98dgkp4zrcd-vimplugin-
Syntastic-2015-02-17.drv’: 1 dependencies couldn't be built

error: build of ‘/nix/store/478msfr0bm6h64zp0ri5c98dgkp4zrcd-vimplugin-Syntastic-2015-02-17.drv’ failed

All the other output appears normal until these last lines. I'm having the exact same problem with other vim plugins, i've tried 4 other plugins:

Solarized
Nerd commenter
airline
ctrp
5

Hmm, we had a wrong hash specified in the expression, it seems. I pushed a fix to master https://github.com/NixOS/nixpkgs/commit/f799749 EDIT: actually the following 46b48b0b4 commit resolved the bad plugins (probably all their hashes were broken).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.