5

I have a wireless router that has settings to use AES, TKIP or AES+TKIP encryption for wireless connections.

My Linux-based device does not like AES (it drops out from time to time), my girlfriend's MacBook Pro does not like TKIP (refuses to connect at all), so it seems I'm stuck with the AES+TKIP setting.

Is there any command I can use to check that my Linux device is using TKIP?
Or even better, one to force it to use TKIP?

2

I believe the tool you are looking for is iwpriv.

iwpriv wlan0 set EncrypType=TKIP

Assuming that your wireless card is wlan0.

  • That just gives me wlan0      no private ioctls. (My interface is wlan0.) – oKtosiTe Aug 12 '11 at 23:02
  • Did you run that as a super? (either as root or via sudo?) – Bryan Agee Aug 12 '11 at 23:04
  • Yes. And iwconfig confirms that wlan0 is the active interface. – oKtosiTe Aug 12 '11 at 23:05
  • You may need to disable network manager and/or ifdown the card before iwpriv will work – Bryan Agee Aug 12 '11 at 23:13
  • Network manager is not installed, but I'll try the latter. – oKtosiTe Aug 13 '11 at 22:25
0

With the new Krack attack, do not use TKIP:

If the victim uses either the WPA-TKIP or GCMP encryption protocol, instead of AES-CCMP, the impact is especially catastrophic. Against these encryption protocols, nonce reuse enables an adversary to not only decrypt, but also to forge and inject packets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.