4

After updating my Debian jessie laptop yesterday, the mute/unmute button stopped working. The volume up/down buttons work and I can mute the sound but when I press the mute button again to un-mute, the 'PCM' control in 'Playback' stays disabled and also the 'Speaker' checkbox under 'Switches' become un-checked.

Here's a quick demo of the faulty behaviour: https://vid.me/LFRi (at around 00:07 mark I press the mute button and then quickly press it again to un-mute yet the PCM and Speaker controls do not change in Alsa Mixer)

Not sure how to go about fixing this, any suggestions?

Thanks.

  • 1
    The mute/unmute buttons did not stop working, the mute button is simply muting the PCM channel along with the Master channel instead of muting just the Master channel as it should. So muting works, unmuting doesn't. According to that video that is. – Cestarian Feb 23 '15 at 0:52
  • @Cestarian The physical button itself does work but I would still say it stopped working as it is not producing the intended result. – Hamza Feb 23 '15 at 17:25
  • 1
    A mute button that mutes but does not unmute can be a hint to the issue that, when using Alsa with pulseaudio, one needs a different command to properly unmute. Since this is discussed on askubuntu extensively, I just link it: here, here and here. – tanius Feb 17 '16 at 1:43
1

I had this same issue, for the same reason (Debian upgrades). I'm using xfce4 for my desktop environment, with xfce4-volumed to control Alsa via PulseAudio.

The solution was to create the following keyboard shortcut:

XF86AudioMute = amixer set Master toggle

There are more "comprehensive" (read: heavyweight) solutions in this guide for Manjaro (an Arch Linux variant) that is applicable to any Linux distro (though you'll want apt-get remove rather than pacman -R, etc).

  • It appears that amixer doesn't accept "PCM" as a control. The problem is, master gets unmuted without a problem. It's "PCM" and the "speakers" switch I have a problem with... – Hamza Mar 2 '15 at 7:20
  • Hm, try an alternate card number, e.g. amixer -c 0 scontrols should list all controls for card zero. I think you can do amixer -c 0 set PCM toggle – Adam Katz Mar 2 '15 at 18:37
0

ALSA upgrades do crazy things sometimes. Try this, in sequence:

  1. stop alsasound
  2. remove ALSA state files: rm /var/lib/alsa/*
  3. restart your computer (ALSA doesn't really stop)

You'll have to tweak your audio settings once your computer has restarted. I for one always did that with alsamixer.

0

The trick is to make the speaker or headphone state follow the state of the master channel depending on if you have the headphones plugged in or not. See my answer and modify the solution to your needs:

https://askubuntu.com/a/757113/238987

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.