I'm trying to install the libfuzzy-dev package on my host machine (Linux Debian 6.0.10 (2.6.32-5amd64 x86_64)).
Installing it via sudo-apt get install shows no results. So I downloaded the .deb file from online and ran the following:

sudo dpkg -i libfuzzy-dev_2.12-1_amd64.deb 
dpkg: regarding libfuzzy-dev_2.12-1_amd64.deb containing libfuzzy-dev:
libfuzzy-dev breaks ssdeep (<< 2.6)
ssdeep (version 2.5-1) is present and installed.
dpkg: error processing libfuzzy-dev_2.12-1_amd64.deb (--install):
installing libfuzzy-dev would break ssdeep, and
deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:

My honest hunch is that one of the sources in sources.list is not really working that well. This is because when I try to re-install ssdeep, it says that it is at the newest version. Any advice?

  • 1
    Paste the output ofapt-cache policy libfuzzy-dev ssdeep into your question, please. And consider upgrading to wheezy. Unless you are using the LTS squeeze support. Feb 22, 2015 at 18:15

1 Answer 1


My guess is that your version of Debian only has quite an old version of ssdeep in its repositories and this version of ssdeep is not compatible with the current release of libfuzzy-dev. I suggest apt-get uninstall ssdeep, then install it (and libfuzzy-dev) 'manually' i.e. not via apt-get.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .