3

I am trying to install fedora 21 server in virtual machine and I am getting following problem. The installation has simply halted. From that description I understand that in some configuration file there is %packages section with no matching %end section. However I am quite new to linux so am quite clueless whats exactly happening.

Will like to know everything about whats going on here. Whats packages? Where this setting is specified? Where and how should I modify it? I am installing VM from ISO file, so how should I approach to modify it if at all necessary.

The ISO I am using is Fedora-Server-DVD-x86_64-21.iso

enter image description here

6 Answers 6

5

Here is also a set of steps I taken to resolve the issue..

enter image description here

Here the error .. the solution..

enter image description here

You have to remove one of the disks .. The "autoinst.iso"

enter image description here

Then you shall be able to build the VM

enter image description here

4

Same problem while creating a new Centos 8 virtual machine with VmWare.

  1. create a VM without OS
  2. start VM
  3. change VM settings to read from CentOS 8 ISO image
  4. restart VM

It works fine for me.

Source: https://bugs.centos.org/view.php?id=16457

1

FYI, I got it to work by not selecting the "Easy Install" or disconnecting the second CD-ROM drive that contains the autorun.iso (or whatever it's named),leaving just the CD-ROM drive that has the ISO. The installer starts right up.

1

If you are looking for a solution to fix the error “Section %packages does not end with %end. Pane is dead” while installing CentOS 8 / RHEL 8 on VMware workstation, then this is the article for you.

The solution to this problem is very simple.

Just after checking the content of autoinst.iso, I thought to remove the extra CD/DVD drive from the hardware setting and it worked without any issue.

Please check the below screenshot for the same.

It seems to be a CentOS 8 bug in the first thought, but after researching I found some people also faced the same issue and were asked to contact their Virtual software vendors.

So I started contemplating and thought to check the settings of my virtual machine on VMware Workstation and surprisingly, I found CD/DVD drive added to my virtual machine hardware settings which were using autoinst.iso image.

Don’t know why VMware Workstation added this extra drive without asking or giving any notice. I tried to analyze the content of the autoinst.iso which was present in the same location as my CentOS 8 virtual machine files according to the error “The following error occurred on line 31 of the kickstart file: Section %packages does not end with %end. Pane is dead”

#langsupport --default en_US
network --bootproto dhcp
cdrom
keyboard us
zerombr yes
clearpart --all --initlabel
part /boot --size 300
part swap --recommended
part / --size 3000 --grow
#part biosboot --fstype=biosboot --size=1
install
#mouse generic3ps/2
firstboot --disable
firewall --enabled
timezone --utc America/Los_Angeles
xconfig --startxonboot --resolution=800x600
rootpw --iscrypted $1$uzIbrDro$RhfwbnmqkvsVwwORfm9Vo1
reboot
auth --useshadow --enablemd5
bootloader --location=mbr
#key --skip
%packages
python
@ X Window System
@ GNOME Desktop Environment
@ Graphical Internet
@ Development Tools

#%end
%post
if [ -f /boot/grub/menu.lst -a ! -h /boot/grub/menu.lst ]; then cp /boot/grub/menu.lst /boot/grub/menu.lst.bak && sed -i 's/ rhgb//' /boot/grub/menu.lst; fi
if [ -f /boot/grub/grub.conf -a ! -h /boot/grub/grub.conf ]; then cp /boot/grub/grub.conf /boot/grub/grub.conf.bak && sed -i 's/ rhgb//' /boot/grub/grub.conf; fi
if [ -f /boot/grub2/grub.conf -a ! -h /boot/grub2/grub.conf ]; then cp /boot/grub2/grub.conf /boot/grub2/grub.conf.bak && sed -i 's/ rhgb//' /boot/grub2/grub.conf; fi
if [ -f /etc/rc.d/rc.local ]; then cp /etc/rc.d/rc.local /etc/rc.d/rc.local.backup; fi
cat >>/etc/rc.d/rc.local <<EOF
#!/bin/bash
echo
echo "Installing VMware Tools, please wait..."
if [ -x /usr/sbin/getenforce ]; then oldenforce=\$(/usr/sbin/getenforce); /usr/sbin/setenforce permissive || true; fi
mkdir -p /tmp/vmware-toolsmnt0
for i in hda sr0 scd0; do mount -t iso9660 /dev/\$i /tmp/vmware-toolsmnt0 && break; done
cp -a /tmp/vmware-toolsmnt0 /opt/vmware-tools-installer
chmod 755 /opt/vmware-tools-installer
cd /opt/vmware-tools-installer
mv upgra32 vmware-tools-upgrader-32
mv upgra64 vmware-tools-upgrader-64
mv upgrade.sh run_upgrader.sh
chmod +x /opt/vmware-tools-installer/*upgr*
umount /tmp/vmware-toolsmnt0
rmdir /tmp/vmware-toolsmnt0
if [ -x /usr/bin/rhgb-client ]; then /usr/bin/rhgb-client --quit; fi
cd /opt/vmware-tools-installer
for s in sr0 sr1; do eject -s /dev/\$s; done
./run_upgrader.sh
if [ -f /etc/rc.d/rc.local.backup ]; then mv /etc/rc.d/rc.local.backup /etc/rc.d/rc.local; else rm -f /etc/rc.d/rc.local; fi
rm -rf /opt/vmware-tools-installer
sed -i 's/3:initdefault/5:initdefault/' /etc/inittab
if [ -f /boot/grub/menu.lst.bak ]; then mv /boot/grub/menu.lst.bak /boot/grub/menu.lst; fi
if [ -f /boot/grub/grub.conf.bak ]; then mv /boot/grub/grub.conf.bak /boot/grub/grub.conf; fi
if [ -f /boot/grub2/grub.conf.bak ]; then mv /boot/grub2/grub.conf.bak /boot/grub2/grub.conf; fi
if [ -x /usr/sbin/getenforce ]; then /usr/sbin/setenforce \$oldenforce || true; fi
if [ -x /bin/systemd ]; then systemctl restart prefdm.service; else telinit 5; fi
EOF
chmod 755 /etc/rc.d/rc.local
if [ -x /bin/systemd ]; then systemctl enable rc-local.service; fi
/usr/sbin/adduser pawan
/usr/sbin/usermod -p '$1$uzIbrDro$RhfwbnmqkvsVwwORfm9Vo1' pawan
/usr/bin/chfn -f "Pawan" pawan
/bin/echo done
#%end```

0

I think that is a bug in Fedora 21 both server and workstation bugzilla. You can try suggested workaround. Create first a Virtual machine with just an empty hard disk. After that connect your Fedora-Server-DVD-x86_64-21.iso and try to install it.

0

guys first shutdown your own machine then go to vm-setting in VMware you notice you have two cd/dvd in list .first cd/DVD have image is autorun.iso and second cd/DVD have real image. select first cd/DVD and remove , restart your machine, problem solved

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .