1

I'm having a problem for which I can't find a solution. I'm currently using an AMD Radeon HD 6870 in dual screen. My left screen is plugged in HDMI and my right screen is plugged in DVI.

My problem is that my left screen works fine while my right screen is only refreshed when I'm changing the window focus or when I do a screenshot.

I did a factice one to be able to show you what's happening everytime, as long as I do not put the focus on an other window :

screenshot

I installed the amd catalyst driver to be able to use both screens but its options looks weird : I can not change the refresh rate of my right dvi screen. Moreover, amd catalyst control center tells me my screen refresh rate is 75hz while arandr tells me it's 60Hz.

Does anybody have a solution for that ? Or have already faced the same problem ?

Edit : Here is my xorg.conf file :

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-DFP5"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-DFP7"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1080"
    Option      "TargetRefresh" "60"
    Option      "Position" "1920 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "Monitor-DFP5" "0-DFP5"
    Option      "Monitor-DFP7" "0-DFP7"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "amdcccle-Device[1]-1"
    Driver      "fglrx"
    Option      "Monitor-DFP5" "0-DFP5"
    BusID       "PCI:1:0:0"
    Screen      1
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   3840 1920
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "amdcccle-Screen[1]-1"
    Device     "amdcccle-Device[1]-1"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Thanks

  • Can you include your X config file in the question? This is probably /etc/X11/xorg.conf or similar. – Faheem Mitha Feb 21 '15 at 15:29
  • Yes, I just edited my post. – Beluga Feb 22 '15 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.