2

I have windows 7 as host. I launch virtualbox with ununtu 14.04 on my Windows 7. I try to launch debian inside Ubuntu: qemu-system-x86_64 -enable-kvm -hda disk.img -boot c -m 256 -localtime.

Another word, there are the following sequence: Windows 7 -> Ubuntu 14.04 -> Debian.

There is a error, when I use key -enable-kvm. Without this key, My debian works very slow. It is launched about 5 minutes. How to fix this trouble? I need the key enable-kvm.

3

You are trying to use KVM, a hardware assisted hypervisor, inside virtualbox, where this is not supported. What you are trying to do is called nested virtualization, and vbox is a poor choice for such a powerful feature.

Without --enable-kvm you end up using pure qemu, i.e. emulation and not virtualization, which is terribly slow indeed.

So, really, things are working as expected, you're simply using the wrong tools if you seriously need to use nesting.

  • I'm pretty sure vbox has a checkbox in the system tab (or something like that) for enable nested virtualization, – mikeserv Feb 21 '15 at 5:06
  • 1
    @mikeserv virtualbox.org/ticket/4032 no movement and none planned. – dyasny Feb 21 '15 at 6:03
  • Weird. I must have been thinking about vmware. I definitely prefer qemu (or, for linux, just namespace containers) to either and it's been a long time since I installed either. I guess my memory just blended the two together. I do know that a -machine q35 can offer a bit of a speed increase for a pure qemu hvm, though. – mikeserv Feb 21 '15 at 6:06
  • @dyasny, yep, you are absolutely right. I understand this theory. But I think, that there is some way to solve my problem. It seems, that I have to choose vmware... – Denis Feb 21 '15 at 8:01
  • Just make sure whatever you choose supports nesting. Your hardware should also support it (IOMMU support) – dyasny Feb 21 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.