2

I have recently installed a copy of Debian 7/Gnome in a partition along with Windows 7.

Even though I am the sole user of this computer, during the installation two accounts have been created: a root with administrative privileges and a second one for myself as regular user.

I am currently experiencing issues in obtaining access to external file systems. Although the system detects the Windows 7 partion, I can't seem to mount the partition successfully, as I click on the icon as regular user, the following message is displayed:

Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://tuxera.com/community/ntfs-3g-faq/#unprivileged

so my second step was to fire up the terminal and type sudo mount -a and now the only message I get as I click on the icon is:

Not Auhorized

The same thing happens when I plug in my external hard drive. I get the same issues. How do I mount successfully these file systems? Is there a way for the system to mount automatically, possibly even at start up if external file systems are detected?

10
  • In Debian to use sudo you have to add your user to the sudoers file. You can also su - or login as root to mount your device manually.
    – YoMismo
    Feb 20, 2015 at 11:53
  • @YoMismo already did that.
    – haunted85
    Feb 20, 2015 at 11:56
  • And couldn't mount the drive? what error messages did you receive?
    – YoMismo
    Feb 20, 2015 at 12:01
  • @YoMismo all the errors I have encountered are reported in my question.
    – haunted85
    Feb 20, 2015 at 12:23
  • Those errors display "unprivileged" and "unauthorized". You still get those same errors when mount is launched from root?
    – YoMismo
    Feb 20, 2015 at 12:25

1 Answer 1

1

I had same issue and editing '/etc/fstab' worked for me.

I had my ext hdd in fstab included like this:

/dev/sdb1 /media/usb0 auto rw,user,noauto 0 0

Deleting whole line helped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .