1

The filesystem usage of redis is peaking every 20 minutes at the moment on my server. Sometimes from 63.1% to over 90.9%! This causes my monitoring to send me alerts if its over a longer time-frame. Is there a way to change the redis config so that this doesn't happen? Here is my current config:

activerehashing yes
appendfsync everysec
appendonly no
bind 127.0.0.1
daemonize yes
databases 16
dbfilename dump.rdb
dir /var/lib/redis
logfile /var/log/redis/redis-server.log
loglevel notice
no-appendfsync-on-rewrite no
pidfile /var/run/redis/redis-server.pid
port 6379
rdbcompression yes
save 300 1000
save 60 80000
save 900 1
slave-serve-stale-data yes
syslog-enabled yes
timeout 300

Graph

0

You need to tune these settings, now you have:

save 300 1000
save 60 80000
save 900 1

Explained:

save N M

means

save redis dataset to disk every Ns if at least M keys changed

My advice is start with the default, which is save 300 1000. It is quite a reasonable setting. My guess is that on your machine these three saves accumulate somehow and then you see a pike.

1
  • Thanks for the reply, sadly changing these values to the default doesn't fix the situation, the peaks are just getting wider but not smaller or less :( – devnull Feb 20 '15 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.