0

I have a server with CentOS 6. I installed on it postgreSQL 9.4, but didn't tell my mate and he installed 8.4 which included in CentOS by default. So we removed (service remove postgresql) both of them and reinstalled 9.4. We are not great Linux users and ruined everything.

Now, I couldn't run - stop - restart postgres. But it was running by default. so I tried to create users. Ups. There was something like "you shouldn't be root". So couldn't create user. It's my 7th hour on forums and there was no solution, whats more is, when I tried the things at the forums everything gone much more bad. Now I cannot even create database cluster (initdb).

(I tried everything with 8.4 too. Also deleted a cpanel package about postgres by accident while trying to clean computer from all postgres packages, and couldn't find it anywhere.)

Can anyone help me on cleaning out my server.

1
  • From the description, I do not think much is damaged. You need to read the manual of Postgres version you want to install. Hopefully, the necessary packages are shipped with an install bundle. Even better, why not try yum. – mkc Feb 20 '15 at 1:49
0

You should (re)start Postgres as user postgres, so first you should su postgres. You should restart your server as well if that's not a big problem, so see if all runs well after a restart. Same goes for creating a cluster. You can do this as user postgres. I thought that you would get a warning about that.

See Installing PostgreSQL 9.4 And phpPgAdmin In CentOS 7/6.5/6.4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.