2

Yesterday I restarted my Notebook with Ubuntu 14.04 and got the following error message in between the login-screen and the loaded user interface.

Error found when loading /etc/profile  
setterm: $TERM is not defined  
As a result the session will not be configured correctly. You should fix the problem as soon as feasible.   

The message reappears with every boot routine. I'm not able to name anything special which could have caused this problem. So far it also has no other visible implications.

What is the problem and how to solve it? I can provide you with every piece of necessary context information as I'm using this computer right now.

My etc/profile file looks like this:

# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "$PS1" ]; then
  if [ "$BASH" ] && [ "$BASH" != "/bin/sh" ]; then
    # The file bash.bashrc already sets the default PS1.
    # PS1='\h:\w\$ '
    if [ -f /etc/bash.bashrc ]; then
      . /etc/bash.bashrc
    fi
  else
    if [ "`id -u`" -eq 0 ]; then
      PS1='# '
    else
      PS1='$ '
    fi
  fi
fi

# The default umask is now handled by pam_umask.
# See pam_umask(8) and /etc/login.defs.

if [ -d /etc/profile.d ]; then
  for i in /etc/profile.d/*.sh; do
    if [ -r $i ]; then
      . $i
    fi
  done
  unset i
fi 
  • To see your currently defined environment variables, open up your terminal and type the command env. To see your environment variable for TERM, if it is defined, in Ubuntu 14.04 type: env | grep TERM. For more information see: Debian Environment Variables wiki. – karel Feb 19 '15 at 9:53
  • env | grep TERM shows TERM=xterm. So - what's the problem? – nevrome Feb 19 '15 at 10:18
  • env | grep TERM on my Ubuntu 14.04 shows two lines of results TERM=xterm and COLORTERM=gnome-terminal. – karel Feb 19 '15 at 10:31
  • 1
    Exactly - I also get the line COLORTERM=gnome-terminal together with TERM=xterm. The error mentions $TERM - so I thought this additional line would not be relevant. – nevrome Feb 19 '15 at 10:35
1

You might try adding -term xterm to the "setterm" line in your .profile

So, for example,

setterm -blength 0

goes to:

setterm -term xterm -blength 0

  • I added the content of my /etc/profile file to my comment. I'm not able to find the setterm option. – nevrome Apr 28 '15 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.