2

I just did:

$ systemctl enable rpcbind

And this caused the volume on my headphones to increase severly.

First off, I don't understand why this happens, as rpcbind seems completely unrelated to my sound? Issuing the command a second time doesn't change the sound, and neither does start rpcbind.

Secondly, I would like to prevent this from happening again; the volume jumped more than a little bit (some panicky actions to remove my headphones accompanied by a loud expletive followed).

This is not the first time I've noticed that systemd commands change my volume by the way... I was playing a HTML5 <audio> tag in Firefox through pulseaudio. I'm running Arch Linux (updated).

4

This is a bug.

The actual root cause is somewhat deeper: systemd's reload logic is flawed. That's why you saw it only when you had actually enabled a unit (i. e. a "disabled -> enabled" transition had taken place): in this case systemd implicitly reloads the units.

I'm working on fixing the bug; in the meantime, if this manifestation (spontaneous volume change) bothers you, you can work around it by using alsa-state.service instead of alsa-{,re}store.service. Refer to manuals or unit files themselves for details on how to use the former instead of the latter.

UPDATE

The bug has been fixed in commit 6e392c9c45643d106673c6643ac8bf4e65da13c1 and will be a part of systemd 220 (unless backported).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.