6

I am using Fedora 21 on my laptop. What I want to accomplish is that, when I switch from wired network to wifi, I don't lose my VPN connection. Tips for accomplishing that would be appreciated in whatever form. I know just enough about networking to be dangerous, and very little about configuring NetworkManager to do anything special. I'm fine with CLI or GUI tools.

It seemed to me that this could be accomplished by bonding the wired and wifi connections into one, and having the VPN use that. I simply can't figure out how to do that. If there is a guide that walks me through it, great. It seems like something everyone would want to do, so maybe there is some reason it's harder than it seems like it should be (that would be useful to know too).

At home, my wifi and wired connection are actually from the same access point. At work, they would be on totally different networks (the wired network is already inside the VPN).

If I try to use the network config GUI to create a bond, the first screen has a place to add bonded connections. Clicking "Add" on that brings up some options, of which only one seems relevant - "Ethernet". There's no place to add a wifi connection; is this just impossible for some reason?

  • What VPN are you using. Both OpenVPN and OpenConnect work fine for me. – Claris Feb 17 '15 at 22:27
  • I guess I should remove the OpenVPN tag since it's actually vpnc, and I don't think I have much choice about that. – sosiouxme Feb 18 '15 at 11:59
2

One option which I use is using my Router to connect to my VPN. This can be accomplished on any dd-wrt, open-wrt, or *BSD router. Depending on your current router you can Google whether your router can be flashed or if it already has the needed capability built in. This is all I can tell with your current set up as described above.

I have never had to do what you are saying but I believe you can set up your connection to only go through if you are connected to your VPN, but I believe this depends on your VPN provider.

  • That would probably work well at home. Thanks! – sosiouxme Feb 17 '15 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.