2

I am trying to configure OpenWRT Barrier Breaker on Archer C7v2 to act as a dumb access point, so the WAN ethernet port will be connected to my network, and anything connected to wifi or the other LAN ports will seamlessly become part of the network with full access. The dumb AP router should also get an IP address via DHCP, so I can connect to it for configuration.

http://wiki.openwrt.org/doc/recipes/dumbap has the instructions I want, I think, but they are in the form of an example with another router that has slightly different hardware and default config. So I'm wanting to check my understanding for this particular router. Especially because failsafe mode on this router appears to be sketchy (https://dev.openwrt.org/ticket/13701 ).

The router model is described here: http://wiki.openwrt.org/toh/tp-link/tl-wdr7500 and I've included the current config below.

Here are some specific questions about http://wiki.openwrt.org/doc/recipes/dumbap as it relates to this router:

  • I think I have the "switch and dedicated WAN" case, correct? (not switchless or switch only)
  • should I move both ports 1 and 6 into vlan 1 and delete vlan 2?
  • I should replace the static IP config with option proto 'dhcp' on the lan interface right? otherwise the main router on the network would also be 192.168.1.1
  • it says to do option ifname 'eth0.1 eth1' but also to delete config interface 'wan', and after that eth0 won't appear anywhere in the file; how does eth0 get attached to vlan 1 such that eth0.1 is the way to write "vlan 1" in the config?

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddc:9283:7080::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6'

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option path 'pci0000:01/0000:01:00.0'
        option disabled '1'
        option txpower '17'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key '***'
        option ssid 'myssid-1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option disabled '1'
        option txpower '30'
        option country 'US'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'myssid-2'
        option encryption 'psk2'
        option key '***'
1

Figured it out (and fortunately the failsafe mode DID work, or I'd be in trouble). The main mistakes I made that were not on http://wiki.openwrt.org/doc/recipes/dumbap were that the vlan was called switch0.1 and not eth0.1; and the wireless radios were disabled for some reason.

The necessary changes in /etc/config/wireless:

/etc/config/network becomes:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fddc:9283:7080::/48'

# added switch0.1 in here and changed to dhcp
config interface 'lan'
    option ifname 'switch0.1 eth1'
    option force_link '1'
    option type 'bridge'
        option proto 'dhcp'
#   option proto 'static'
#   option ipaddr '192.168.1.1'
#   option netmask '255.255.255.0'
#   option ip6assign '60'

# commented out
#config interface 'wan'
#   option ifname 'eth0'
#   option proto 'dhcp'

# commented out
#config interface 'wan6'
#   option ifname '@wan'
#   option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

# added 1 and 6 here
config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4 5 6'

#config switch_vlan
#   option device 'switch0'
#   option vlan '2'
#   option ports '1 6'

Then, as documented on the wiki, disable the firewall and the dhcp server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.