6

I am trying to install this software called acqu-root. It depends on the main software called root. I managed to install the main software but having problems with the acqu-root. I get the following error.

[kabi@localhost build]$ cmake ..
-- *** Build Type:      Debug
-- *** Compiler Flags:  -g -O0 -Wall
-- *** Install libs to: /home/kabi/acqu-root/build/lib
-- *** Install bin to:  /home/kabi/acqu-root/build/bin
-- Looking for ROOT...
-- Looking for ROOT... - Found /home/kabi/root/bin/root
-- Looking for ROOT... - Found version is 6.03/01 
-- Configuring acqu_core...
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find LibLZMA (missing: LIBLZMA_INCLUDE_DIR LIBLZMA_LIBRARY
  LIBLZMA_HAS_AUTO_DECODER LIBLZMA_HAS_EASY_ENCODER LIBLZMA_HAS_LZMA_PRESET)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindLibLZMA.cmake:57 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  acqu_core/CMakeLists.txt:9 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/kabi/acqu-root/build/CMakeFiles/CMakeOutput.log".
9

You need to install lzma-devel using yum (Fedora, RHEL, CentOS...), or liblzma-dev using apt-get or aptitude (Debian, Ubuntu...); it contains LibLZMA which the CMake configuration is looking for.

| improve this answer | |
  • Hi, I tried installing the software on the Ubuntu, but I couldn't find the package lzma-devel, there is only lzma-dev could you instruct me how to install lzma-devel on Ubuntu? or how to remove lzma-devel references from cmake? – Santosh Linkha Feb 17 '15 at 13:45
  • I was going by the Fedora tag; on Ubuntu it is just lzma-dev or liblzma-dev depending on what your source really needs. – Stephen Kitt Feb 17 '15 at 14:01
  • thanks .. installing liblzma resolved the error. earlier I had tried installing this on fedora, now I am trying this on ubuntu. – Santosh Linkha Feb 17 '15 at 14:15
7

Try

yum install xz-devel

on Centos to get the liblzma libraries (for Silver-searcher, for example. Also may need pcre-devel for the libpcre dependency)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.