14

I'm on Ubuntu 14.04.

I pasted something incorrect (from a tutorial) into my /etc/fstab file. As a result, the root file system will not mount when the machine boots up.

I know what needs to be fixed in /etc/fstab, but I cannot save the file (or any file) because the system boots as read only.

As root, I tried:

mount -o remount,rw /

to no avail. The error message cited the section of bad options that I pasted into /etc/fstab.

I read some stuff about booting into single user mode by adding 'single' to the end of the kernel parameter. I can't seem to find the kernel parameter. On the grub menu, I highlight Ubuntu and press 'e' which brings up a file with some sort of configuration, but there is no 'kernel' parameter to be found.

I'm relatively new to linux. Can anyone help me figure out a way to fix my /etc/fstab file so that Ubuntu will boot normally?

  • Can you make a live USB and boot to it? The kernel parameter is the line that begins with linux .... – muru Feb 15 '15 at 22:09
  • ah thanks for pointing out which is the kernel parameter. i will try to add 'single' to the end of it and follow instructions from there. – Daveh0 Feb 15 '15 at 22:31
  • 2
    mount -o remount,rw / should work. What are the exact error messages? – Gilles 'SO- stop being evil' Feb 15 '15 at 22:38
  • @Gilles - it worked after I booted into single user mode – Daveh0 Feb 15 '15 at 22:55
16

The way you have tried the mount command still uses the information from /etc/fstab.

Try the following version and it should work independent of the contents of /etc/fstab:

mount -o remount,rw /dev/sdb6 /

Note: Instead of /dev/sdb6, use whatever device is valid for your drive.

  • Thanks! Just had the same problem, and you (and Google) fixed it for me. – Thomas Padron-McCarthy Jun 29 '16 at 17:09
5

To get things back to where they should be, I:

  1. Highlighted 'Ubuntu' at the boot menu
  2. hit 'e' to edit the configuration
  3. in the line starting with linux=, I switched the 'ro' to 'rw' and added the word 'single' at the very end of the line
  4. hit f10 to boot
  5. once it booted, as root, I did:

    mount -o remount,rw /
    
  6. as root, I edited /etc/fstab to get it where it needed to be

  7. rebooted normally and everything seems to be fixed
  • gained root privileges sudo su - then ran mount -o remount,rw / worked on raspbian too (y) – Ciasto piekarz Oct 26 '17 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.