1

I was given a Acer Aspire One A110 Netbook (ca. 6 years old) with Ylmf OS.

So far I get along quite well, but one problem remains - unsolved:

  • Although my WLAN is correctly set up and works with other computers I can't connect to the internet on my Aspire One.

When turning on the netbook I can choose start options. I choose the option where it gives the information: Ylmf OS, Linux 2.6.31-17-generic. No problem, username and password, and I reach the screen with all the icons etc.

The tray at the bottom right corner shows the icon of two screens and red cross, the tooltip says: "No Network connection". Right click on the icon opens a little window. The checkboxes "Enable Networking" and "Enable Notifications" are activated, "Enable wireless" is not available for checking. Information on the Network Manager is Applet 0.7.998. Left click on this icon opens a window, I read: Wired network: disconnected, Wireless Networks: wireless is disabled.

The icon on the top right corner of 3 connected screens offers no possibility to enable the network, neither by left or right mouseclick.

I went through "Start" > "System" > "Preferences" > "Network Connections" > "Wireless" (Tab) and added the name of my WLAN and edited it with SSID name, Ad-hoc Mode, WPA & WPA2 Personal Security and password and said "Apply".

I also went through "Start" > "System" > "Administration" > "Network Tools" > "Devices" (Tab) und changed from "Loopback interface (lo)" to "Wireless Interface (wlan0)". Since there's no way to save this I just closed the window. Returning to it once again the change was undone.

Still: I can't connect to the Internet/to my WLAN.

Supplement: On it's body Acer Aspire AOA110 model has an external manual switch to turn on/turn off wifi. This switch is correctly working. fn+F2 or fn+F3 are not working for this purpose. My private WLAN is working correctly: When operating my Aspire with Windows XP Pro (installed) connecting to the internet via WLAN is working correctly. The switch is working correctly when running the netbook with Windows XP.

I tried sudo rfkill list; it returned:

0: phy0: Wireless LAN
soft blocked: no
hard blocked: no

migrated from askubuntu.com Feb 15 '15 at 18:16

This question came from our site for Ubuntu users and developers.

0

Wireless Networks: wireless is disabled

This indicates that no wireless network interface is available. This could be either because you're missing the appropriate driver, or because the wifi is disabled.

Linux kernel 2.6.31 is from 2009, so it's possible that your driver is too old for this chip. The Arch Wiki lists 2.6.27 as the minimum kernel version, but it's possible that some models have a more recent version of the chip that requires a more recent driver.

It's also possible that the wifi is disabled. Many laptops have a wifi and Bluetooth kill switch that turns off these chips to save energy. This can be either a button on the side or on the top, or an Fn+ key combination. If you can't find the button, you should be able to enable it in software: install the rfkill package and run sudo rfkill unblock all on the command line.

  • :I am not familiar with LINUX. To install the rfkill package could I follow the instructions given on control-escape.com/linux/lx-swinstall.html? My steps would be: 1. connect the netbook to internet by means of a ethernet cable. 2. run apt-get update 3. run apt-get install ${rfkill} 4. run sudo unblock all – Acer AOA110 Feb 18 '15 at 12:44
  • @AcerAOA110 Yes, that would work (you can use the GUI instead of the command line if you prefer, I don't know what package management GUI your distribution provides). If you aren't familiar with Linux, it might be worth trying a more recent distribution instead, which should work out the the box. – Gilles Feb 18 '15 at 13:39
  • Thank you. Tried so many times so many things - and suddenly I got connected to the internet; can't explain what really made it possible; it must have to do something with my network seen as hidden... Anyway: I keep your advice. And many thanks! Problem resolved, question closed. – Acer AOA110 Feb 19 '15 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.