3

I installed cifs-utils, and can mount the remote drive using the command

sudo mount.cifs //DRIVE ~/homedir/ -o user=user,pass=pass,sec=ntlmssp

However, the user account cannot write to the mounted folder, despite the fact that there are no access restrictions on the server side after inputting the credentials.

sudo mount.cifs //DRIVE ~/homedir/ -o user=user,pass=pass,sec=ntlmssp,umask=000

still does not work.

More strangely though, attempting to run the aforementioned commands as user results in mount.cifs: command not found

What would be the correct command to mount the folder so it is writeable by user?

1
  • You need to specify that the user account has write access to the mount point. Read the manual page for mount.cifs
    – Petesh
    Feb 14 '15 at 20:22
3

To make ordinary user to operate with remote share you should add the user's id to the option like

sudo mount.cifs //DRIVE ~/homedir/ -o user=user,pass=pass,sec=ntlmssp,uid=1000,gid=46

where

  • uid - user id which can found in id command output
  • guid - user group id ( but in some case you'd better use plugdev group which equal 46)
2
  • Okay, but is there any explanation for the umask options failing to work, and the user not being able to access the mount command at all?
    – March Ho
    Feb 14 '15 at 20:39
  • @MarchHo umask works for new files which you will made after mounting. Mounting is a system operation which allow just to administrator so did not allowed for ordinary user. More over such user is to operate just inside of his home directory.
    – Costas
    Feb 14 '15 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.