3

I keep getting this same error when trying to install various packages:

make: error while loading shared libraries: libunistring.so.0:
cannot open shared object file: No such file or directory

It's occurred while trying to install the Ruby gem Gosu as well as some free Linux games like Alien Arena. I even tried re-installing libunistring with pacman to no avail.

  • Please post the output of pacman -Q libunistring – jasonwryan Feb 14 '15 at 2:01
  • Output for pacman -Q libunistring: libunistring 0.9.4-1 – Ethan Wilkins Feb 14 '15 at 2:48
  • That PKGBUILD (ruby-gosu) is out of date, but with a small modification it builds fine. Is your glibc up-to-date? Are you using yaourt (because you should build manually if it fails)? Also, please don't paste truncated error output: it makes it too hard to guess what is going on, paste the whole thing. – jasonwryan Feb 14 '15 at 3:01
  • 1
    Then your system is likely out-of-date, or you have borked it somehow. Run pacman -Syyu. – jasonwryan Feb 14 '15 at 3:19
  • 1
    It's ridiculous: I install a fresh base/arch image, I run pacman -S make, it succeeds, I run make and it says make: error while loading shared libraries: libunistring.so.2. Arch Linux sux. – rustyx May 29 '18 at 9:30
0
pacman -Syyu

Fixed the issue as provided by jasonwryan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.