7

The list accessible in Settings>Applications>Startup is empty by default:

enter image description here

Here and in other places I found the idea that running this command should solve it:

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

But it does not.

9

The application to start is called gnome-session-properties (part of gnome-session-bin). There the list can be edited.

enter image description here

Any changes there will then appear in the other list accessible from Settings>Applications>Startup; thus, the latter is limited only to reverting to defaults.

enter image description here

In order to access that in the Panel Launcher (Applications), I have created a .desktop file inspired by the other such files that can be found in usr/share/applications with this content:

[Desktop Entry]
Type=Application
Name=StartupApps
Comment=View apps starting with the system
GenericName=StartupApps
Icon=preferences-system
Terminal=false
Categories=Gnome;Gtk;System;
Exec=gnome-session-properties

So that it now can be found when searched or under Applications>System Tools

enter image description here

  • gnome-session-properties is no longer available in the repositories. Was it renamed to something else? – Sarvex Nov 11 '17 at 10:04
  • @Sarvex - you should ask a specific question on elementaryos.stackexchange.com. I am not using elementary at this time. – user32012 Nov 11 '17 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy