0

I added ipv6 to Raspbian (debian) on my Raspberry Pi using modprobe

I do not use it, and want to remove.

I tried sudo modprobe -r ipv6 but get error FATAL: Module ipv6 is in use.

The only process I can find running is ipv6_addrconf which I can't seem to kill.

2
  • does it cause any problems? did you try to reboot?
    – michas
    Feb 12, 2015 at 23:18
  • I causes no problems, but uses a lot of memory (which the Pi doesn't have) and I am not using it.
    – Milliways
    Feb 12, 2015 at 23:29

2 Answers 2

1

Solved. I removed ipv6 from /etc/modules

1

After a reboot your kernel should first start without any modules. Modules are then loaded either explicitly via /etc/modules or automatically on detection of devices or manually via modprobe/insmod.

To avoid automatically loading you can blacklist those modules.

Therefore make sure it is not listed in /etc/modules and simply reboot your box. If your module is gone, fine, simply do not load it manually again. ;)

If you module is still there, it was loaded automatically. In this case blacklist it and do another reboot.

1
  • I tried blacklist with no effect /proc/modules shows ipv6 351566 24 [permanent], Live 0xbf079000
    – Milliways
    Feb 13, 2015 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .