1

I've recently installed Fedora 21 Workstation and I want to install the VirtualBox package from RPM Fusion. But it is giving me problems.

$ uname -a
Linux a10-5800k 3.18.5-201.fc21.x86_64 #1 SMP Mon Feb 2 21:00:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo yum install VirtualBox kmod-VirtualBox
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox.x86_64 0:4.3.20-3.fc21 will be installed
--> Processing Dependency: libSDL-1.2.so.0()(64bit) for package: VirtualBox-4.3.20-3.fc21.x86_64
---> Package kmod-VirtualBox.x86_64 0:4.3.20-4.fc21.3 will be installed
--> Processing Dependency: kmod-VirtualBox-3.18.6-200.fc21.x86_64 >= 4.3.20-4.fc21.3 for package: kmod-VirtualBox-4.3.20-4.fc21.3.x86_64
--> Running transaction check
---> Package SDL.x86_64 0:1.2.15-17.fc21 will be installed
---> Package kmod-VirtualBox-3.18.6-200.fc21.x86_64.x86_64 0:4.3.20-4.fc21.3 will be installed
--> Processing Dependency: kernel-uname-r = 3.18.6-200.fc21.x86_64 for package: kmod-VirtualBox-3.18.6-200.fc21.x86_64-4.3.20-4.fc21.3.x86_64
--> Finished Dependency Resolution
Error: Package: kmod-VirtualBox-3.18.6-200.fc21.x86_64-4.3.20-4.fc21.3.x86_64 (rpmfusion-free-updates)
           Requires: kernel-uname-r = 3.18.6-200.fc21.x86_64
           Installed: kernel-core-3.17.4-301.fc21.x86_64 (@koji-override-0/$releasever)
               kernel-uname-r = 3.17.4-301.fc21.x86_64
           Installed: kernel-core-3.18.5-201.fc21.x86_64 (@updates)
               kernel-uname-r = 3.18.5-201.fc21.x86_64
           Available: kernel-debug-core-3.17.4-301.fc21.x86_64 (fedora)
               kernel-uname-r = 3.17.4-301.fc21.x86_64+debug
           Available: kernel-debug-core-3.18.5-201.fc21.x86_64 (updates)
               kernel-uname-r = 3.18.5-201.fc21.x86_64+debug
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The problem is that the RPM Fusion kmod-VirtualBox.x86_64 points to kmod-VirtualBox-3.18.6-200.fc21.x86_64. There is an available kmod-VirtualBox for my current kernel and I try to install that like so.

$ sudo yum install VirtualBox kmod-VirtualBox-3.18.5-201.fc21.x86_64.x86_64

But I still get the same dependency check error as above. I guess my question is how do I install VirtualBox so that it uses the kmod with the same kernel Fedora 21 is using?

I have tried updating as of this post but Fedora 21 still doesn't have the 3.18.6-200.fc21 kernel available.

3

I guess my question is how do I install VirtualBox so that it uses the kmod with the same kernel Fedora 21 is using?

There is an alternative solution to your problem, it would be to use akmod-VirtualBox.

How & why to use rpmfusion's "automagical" source akmods instead of regular binary kmods (kernel modules).

akmods (similar to dkms) is a solution to the problem of some kernel modules
depending on specific versions of a kernel. If you want to use a custom kernel,
or a test kernel -- e.g. from updates-testing or koji -- or if there is a very
new kernel in the updates repo, then you must either wait for rpmfusion to
rebuild binary kmods to match, or you must yumdownload and rpmbuild the source
rpm manually. Enter a better way: automatic kmod rebuilding.

Here's how you install akmod-VirtualBox with yum:

Install rpmfusion repositories:

Fedora 14 to the most current:

su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

Install akmod:

yum install akmod-VirtualBox kernel-devel-$(uname -r); akmods

If you installed VirtualBox packages and haven't rebooted the system, you may need load the kernel driver, doing so as root: 'systemctl restart systemd-modules-load.service'

Source

  • My problem has now been resolved as kernel 3.18.6-200.fc21 is now in updates (was in testing when I was trying to upgrade VirtualBox). I was thinking of using akmod-VirtualBox but I saw that there was an existing kmod for 3.18.5-201.fc21 so I didn't bother doing it. I just wanted a way to force using the kmod by specifying the version I wanted for my kernel but it was still a no go. – baktin Feb 15 '15 at 3:51
  • 1
    This answer should be accepted because it works even in when the right kmod package is not in the repository. This happens from time to time, using akmods as described here is a pretty reliable solution. It's important to install the dependencies as well (as described), like kernel-devel (the uname part isn't really necessary, the current version is installed if no version is specified). – basic6 Jul 11 '15 at 22:14
0

There are two options but you may encounter additional problems concerning your other packages. First one is to use updates-testing repository where required kernel exists.

yum-config-manager --enable  updates-testing 

Than you can install required packages. The second option is to install and boot with older kernel I think in your case is: kernel-core-3.17.4-301.fc21.x86_64 and than to install older package e.g. kmod-VirtualBox-4.3.20-2.fc21 but I do not recommend it.

  • but the new kernel is already available so you will need only to update. – taliezin Feb 13 '15 at 15:07
0

As of this post, Fedora just got the 3.18.6-200.fc21 kernel and I've updated to it. I'm now able to install the VirtualBox package from RPM Fusion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.