3

I'm not able to install/run Dropbox on Linux Mint 17.1.

I installed dropbox package from repository (and also from archive on official site - same results):

sudo apt-get install dropbox python-gpgme

When I run Dropbox from menu and accept installation prompt, Dropbox downloads successfully and then proceeds to unpacking. Unpacking gets stuck at 99% and then dissapears after a while without Dropbox actually starting.

When I run it from commandline, it outputs following error and behaves the same.

$ dropbox start -i
Starting Dropbox...Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "__main__.py", line 3, in <module>
Done!
$ dropbox status
Dropbox isn't running!

It's pretty much a clean install of Linux Mint 17.1 and python is able to import os when executed from commandline:

$ python -c "import os; print(os)"
<module 'os' from '/usr/lib/python2.7/os.pyc'>
$ python3 -c "import os; print(os)"
<module 'os' from '/usr/lib/python3.4/os.py'>

What should I do to debug/fix this problem?

  • 1
    I have the same problem, and posted a question in the Dropbox forums: dropboxforum.com/hc/communities/public/questions/… – UrkoM Mar 3 '15 at 1:02
  • Where do you see the error about os? Is the traceback incompletely copy/pasted here? – tripleee Apr 22 '17 at 5:26
  • Debugging this is probably going to reveal an unrelated problem, possibly an XY problem, and require some programming and/or system administration skills. Are you able to debug Python programs? Can you identify the relevant parts in the output from strace -f dropbox (and ideally also edit your question to include them here)? – tripleee Apr 22 '17 at 5:35
1

I encountered this problem in early 2017 on Ubuntu 16.04. By using strace -f dropbox, as suggested by triplee, I indentified that the issue was with the version of python being unable to access the files inside ~/.dropbox-dist/dropbox-lnx.x86_64-32.4.23/library.zip.

The solution required several steps:

  1. extract the contents of library.zip
  2. set the permissions on all the files/folders so they are readable (they weren't for some reason)
  3. rename the file dropbox to dropbox-bin
  4. edit dropboxd to point to the newly-renamed dropbox-bin
  5. move the files extracted from library.zip to the folder that contained library.zip

The reason for steps 3+4 is that library.zip contains a folder called dropbox.

-2

The answer here is very simple, from a terminal.

sudo apt-get install dropbox

If root, apt-get install dropbox

I just did this 2 days ago when I installed Mint 17.2 Rafaela Cinnamon x64.

Note, previously I used 17.1 Rebecca Xfce x86 and the terminal command was exactly the same.

This is the answer to your post title.

Once this install was complete, all I did was open the Menu, typed Dropbox in search, clicked on Dropbox when presented, and Dropbox launched which then proceeded to ask me for my username and password.

  • 2
    I might anwser the post title, but I don't see how it anwers the question. You are saying that you installed Dropbox standardly without encountering the described issue? How does that help me when I do encounter it? – Jakub Stejskal Jul 23 '15 at 14:58
  • You are installing it using, sudo apt-get install dropbox python-gpgme, instead of the standard method. Common troubleshooting suggests finding a work around to get it installed, then research and diagnose the original issue and see if there is something in your way breaking the install opposed to the standard way. – Christopher S. Atkins Aug 3 '15 at 3:35
  • 2
    That is in no way a correct answer. First, OP tried the command that includes yours, and in no sane environment adding another installed package should break an existing one unless they are marked so. Second, it does not help me, just stuck with the same issue. And yes, Dropbox on one of my ubuntu 15.10 (+KDE) computers works great, another one (headless server) does not work at all. So your solution only helps when there is no problem installing dropbox ;). I filed a detailed bug report, we'll see what happens… – gluk47 Mar 24 '16 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.