3

How can I install pulseaudio on lubuntu? When I try installing via sudo apt-get install, the package is not available.

I use kodibuntu (formerly xbmcbuntu) and want to get pulseaudio working to get sound in Grim Fandango Remastered to play properly.

  • 1
    So sudo apt-get update && sudo apt-get install pulseaudio pavucontrol doesn't work? You may then try to use this ppa – kirill-a Feb 11 '15 at 14:39
  • Pavucontrol exists, and recommends pulseaudio, which doesnt exist. I will try that ppa,thanks – user3207230 Feb 11 '15 at 15:30
  • That ppa only gives me "404 Not Found" – user3207230 Feb 11 '15 at 15:48
  • Pulseaudio is in main, so if it isn't available, there's something wrong with your sources. Which version? – muru Feb 11 '15 at 17:07
  • Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS - KODIbuntu Release: 14.04 Codename: trusty I dont understand what is wrong? – user3207230 Feb 11 '15 at 17:30
1

Kodibuntu blocks the pulseaudio packages from being installed by apt.

You can undo the block by removing/moving the following files:

  • /etc/apt/preferences.d/libasound2-plugins.pref
  • /etc/apt/preferences.d/libasound2-plugins.pref.bak

After this you can do another apt-get update and you should be able to install the packages.

1

You can not install pulseaudio on Kodibuntu before you unlock the package.

To do so, remove /etc/apt/preferences.d/pulseaudio.pref by entering:

sudo rm /etc/apt/preferences.d/pulseaudio.pref

Alternatively you can also move the file to a backup location.

Afterwards you can install PulseAudio by entering:

sudo apt-get update && sudo apt-get install pulseaudio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.