I cannot change my login screen background to the desktop background in my elementary os which is based on ubuntu. I have decrypted my home folder according to this link:


and when I ran the command to check for encryption I got the following result-

~$ ls -A /home

lost+found     ramiz

[note: no .ecryptfs folder there!!]

~$ sudo blkid | grep swap

/dev/sda5: UUID="00ec9e13-4cfe-4f73-905a-fef05d73caa2" TYPE="swap"

I have come to understand that it means neither my home nor swap partition is encrypted. Still I cannot change my login screen wallpaper. I have tried the simple version given in the official website - i.e.,

1) Open “Files”

2) In plank, right click on “Files” and click “Open new window as admin”

3) Insert your password

4) On the new ADMIN window, go to: /usr/share/backgrounds

5) Paste your new image file there [/usr/share/backgrounds] (make sure it’s a JPEG file with, at least, 1920x1080 resolution)

6) Go to “System Settings”, “Desktop” and your new image file should be there

7) Click on it

8) Log out

This wasn't helpful so I went for the decryption as I read that it was due to the fact that my home folder is encrypted that I cannot change my login screen background to the wallpaper I downloaded. (I read that here:- http://elementaryos.org/answers/login-screen-isnt-the-wallpaper-i-want-i-also-want-to-delete-all-the-default-wallpapers-1 )

Please help me. I have installed elementaryos for a friend of mine recently and she doesn't have this problem. I could change my login screen before(have tried only once!) but cannot anymore. I always thought that the lock icon beside my partition in the gparted app is saying that its encrypted. The lock icon is there.

Screenshot of my gparted Please help me!!

3 Answers 3


Got it!

1) Copy all the pics to /usr/share/backgrounds

2) Then take terminal and change directory to that folder.

   cd /usr/share/backgrounds

3) Then for every image_name.jpg that you just added, type the command:

   sudo chmod a+rw image_name.jpg 

4) Now exit terminal and check your System settings -> Desktop . Your custom wallpapers will be available there. Selecting from it also changed the login screen background in my lightdm.


I developed a function in shell script.

ChangeBackgroundLogin () {
   sudo cp $1 $p
   sudo chmod 644 $p

Only need put this function in your .bashrc

And execute

ChangeBackgroundLogin 'myImage.jpg'

  1. sudo cp your_wallpaper.jpg /usr/share/backgrounds/
  2. sudo chmod 644 /usr/share/backgrounds/your_wallpaper.jpg
  3. sudo nano /usr/share/gnome-background-properties/trusty-wallpapers.xml
  4. Go to the bottom of the file and above the last </wallpapers> tag, copy the text:
</wallpapers> <-- This should be the last line - copy the above text
  1. Save file and exit.
  2. Open System Settings->Appearance->Look tag->Wallpapers from the expanding window. And finally choose your wallpaper which will appear now with the name Name_of_your_wallpaper.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .