4

A couple of months ago, I re-installed Cygwin on my Win7 machine. Since then, when clicking the XWin Server entry in the Start Menu, it not only starts the (familiar) X tray icon along with a xterm window (this is running in "rootless" mode), but also a frame-less, grey window with the same (slightly larger) X icon.

It is placed in the screen's top-left corner and on being clicked, it offers a small menu of applications to execute and to "Exit Cygwin/X". Its taskbar entry shows "panel" as its window title.

Since this "panel" window's functionality is duplicated in the tray icon's right-click menu (which has more options anyway), I am wondering how to suppress the start of this window.

I had a look at the man pages for Xwin and XWinrc as well as the files under /etc/X11/xinit/, but since I am new to X11 I might have missed something. The Manpage of XWin and the Configuring Cygwin/X pages weren't helpful either.

3 Answers 3

2

I found fbpanel is here /etc/X11/xinit/startxwinrc
in the condition

if [ -f $HOME/.startxwinrc ] then
  exec $HOME/.startxwinrc
else
  ...
  /usr/bin/fbpanel
fi

so I've created $HOME/.startxwinrc with the only /usr/bin/xterm
(warning: line endings must be unix single LF)
it helped, no panel, only xterm window opens

1
  • +1 Thanks for that, this is another valid answer. One disadvantage I noted with this option though: Once I exit the xterm window, the whole server seems to shut down, at least the X icon in the systray disappears. Which might still be better than having the warnings "4 clients connected" when I click Exit in the systray menu given by my original installation.
    – FriendFX
    Feb 18, 2015 at 23:13
1

I launch my X Server with this: "XWin.exe -multiwindow"

2
  • 1
    Thanks, that seems like a much more lightweight solution than the one in the Cygwin default installation, which has the following (for me somewhat mysterious) command line: C:\cygwin\bin\run.exe --quote /usr/bin/bash.exe -l -c "cd; /usr/bin/startxwin". I do wonder what I am missing when switching to this, much shorter version (other than not having an xterm window show up automatically)? Could you elaborate how you got to your solution, e.g. where can relevant documentation be found?
    – FriendFX
    Feb 12, 2015 at 22:57
  • This worked for me: c:\cygwin\bin\run.exe XWin -multiwindow -clipboard -silent-dup-error Mar 4, 2015 at 9:18
0

If you put a sleep command a the end of $HOME/.startxwinrc, and run your xterm in the background like this:

/usr/bin/xterm -ls &
sleep inf

It should avoid the whole session closing when the initial xterm closes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .